Author Topic: No Unicode support in ZIP archives created using Windows XP  (Read 3220 times)

Timon

  • Active Member
  • ***
  • Posts: 34
    • View Profile
Multi Commander 3.5.1 build 1530

Create any file in russian, for example "тестовый документ с русскими буквами в названии.txt". In Windows Explorer (under Windows XP SP3) right click on that file and select Send to - Compressed zip folder. Now we get archive "тестовый документ с русскими буквами в названии.zip"
If we try to open such archive with Multi Commander, we see only inexplicable symbols instead of russian.

In other commanders (like Total Commander or FreeCommander XE) the same file is opened without any problems.

If we pack file "тестовый документ с русскими буквами в названии.txt" using Multi Commander in zip format, content of archive is shown correctly.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3291
    • View Profile
    • Multi Commander
Re: No Unicode support in ZIP archives created using Windows XP
« Reply #1 on: October 10, 2013, 07:56:36 »
Zip does no support Unicode, There is an extension to the standard that gives support for UTF8 and MC do support that. But not many programs uses UTF8 when creating zips.
The problem is that ZIP is an very old standard and it only support US ASCII. But a common "hack" is to use the codepage the OS is set to instead.
and MC will do that (unless it set not to do that),  But some language have multiple codepages and you then might need to force zip into a different codepage.

At the moment there is no settings page for that in MC but there is a command you can type in the command line field

":zipcp -1" - Use OS Default codepage  (default)
":zipcp 866"  - Force Zip to use codepage 886 - ( OEM Russian; Cyrillic (DOS) )
":ziputf8 1" -  Use UTF8 when Creating zip files. ( 0 to turn it off)