Author Topic: search files  (Read 640 times)

Jean

  • Contributor
  • Active Member
  • *****
  • Posts: 47
    • View Profile
search files
« on: April 12, 2020, 13:31:21 »
Hi folks,
What am i doing wrong, i'm trying to search a map for filenames with the word 'on', but it shows me wrong results. Explorer shows the files are there.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3602
    • View Profile
    • Multi Commander
Re: search files
« Reply #1 on: April 13, 2020, 14:30:35 »
That in correct, all the matches contains "on", if you want to match the word on. Then you need space around it. But spaces are a separate for multiple words to match.
But as it say under the text box. Use quote around it if you need spaces in the word that should be matched, like " on "  (And include the " )



Jean

  • Contributor
  • Active Member
  • *****
  • Posts: 47
    • View Profile
Re: search files
« Reply #2 on: April 13, 2020, 14:42:22 »
sorry for the fuzz, it's working now. Dunno why it didn't before.

Jean

  • Contributor
  • Active Member
  • *****
  • Posts: 47
    • View Profile
Re: search files
« Reply #3 on: April 15, 2020, 12:05:14 »
Mathias, i get the error again, look at the pic, it's supposed to find Adams*.ab, as you can see the file is present but the search results are empty. Explorer finds the file. It's the only search criterium, i don't see what i'm doing wrong.
Then i switched to normal mode, did the same search and now it finds them all.
Can't make much sense of it, seems very random.
« Last Edit: April 15, 2020, 12:20:43 by Jean »

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3602
    • View Profile
    • Multi Commander
Re: search files
« Reply #4 on: April 15, 2020, 13:39:54 »
Change "namepart" to "fullname"

Namepart match only against the filename without extensions part..  "MyFile.txt" (Fullname)  and "MyFile" (Namepart)

Jean

  • Contributor
  • Active Member
  • *****
  • Posts: 47
    • View Profile
Re: search files
« Reply #5 on: April 15, 2020, 14:24:15 »
Yes i think that was my mistake, thanks again.