Author Topic: Avoid white flashback when opening a tab in dark theme?  (Read 420 times)

jeycool

  • Junior Member
  • **
  • Posts: 12
    • View Profile
Avoid white flashback when opening a tab in dark theme?
« on: November 12, 2020, 03:23:04 »
Hi

Is it possible to not have any white flashign when opening a new tab while using the dark theme? Basically there is a sudden white background then dark background change when opening a new tab.  It is  a minor annoyance, I thought I would report it.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3676
    • View Profile
    • Multi Commander
Re: Avoid white flashback when opening a tab in dark theme?
« Reply #1 on: November 12, 2020, 07:02:01 »
Have you restarted MC since you turned it on ?

I cannot reproduce that on any machine, There should not be any initial draws using default color if MC was started with DarkMode on.

jeycool

  • Junior Member
  • **
  • Posts: 12
    • View Profile
Re: Avoid white flashback when opening a tab in dark theme?
« Reply #2 on: November 12, 2020, 18:03:44 »
Hi

Yes I restarted it many times since setting dark theme. And my pc is relatively fast.

Please see the video, you can see the flashing when I open a new tab.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3676
    • View Profile
    • Multi Commander
Re: Avoid white flashback when opening a tab in dark theme?
« Reply #3 on: November 12, 2020, 21:19:43 »
Strange, then something else is causing it to flash. normally it does not do that.
It been tested on many different machine without any issue. So something is unique with your setup that make it not work
Sometimes it can be that the gfx driver does not support it since Windows does not fully support dark mode for desktop apps this way.


jeycool

  • Junior Member
  • **
  • Posts: 12
    • View Profile
Re: Avoid white flashback when opening a tab in dark theme?
« Reply #4 on: November 12, 2020, 23:48:06 »
I have a gtx 1070.