Author Topic: Silent move?  (Read 629 times)

nok32

  • Newbie
  • *
  • Posts: 7
    • View Profile
Silent move?
« on: October 10, 2021, 22:15:28 »
Hi, there was a recent update and now moving files around makes a popup progress bar and a sound and I just want it to be a normal silent process again without any popup. Where is this option? And fyi it didn't do this before the update so maybe try not to alter those basic settings.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3886
    • View Profile
    • Multi Commander
Re: Silent move?
« Reply #1 on: October 11, 2021, 14:11:04 »
Core Settings > FileSystem

nok32

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Silent move?
« Reply #2 on: October 11, 2021, 22:15:25 »
Ok I tried. The settings in that menu don't affect the issue. When I drag/drop a file to move it a progress window opens and a completed sound plays. It also will sometimes say 0% completed even though it completed successfully.
« Last Edit: October 11, 2021, 22:18:41 by nok32 »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3886
    • View Profile
    • Multi Commander
Re: Silent move?
« Reply #3 on: October 11, 2021, 22:26:19 »
Well the progress bar will always be shown. But you can configure it to autoclose,  You disable the Confirm and option dialog (by doing that you will no longer be able to use any of the advanced copy features)
Hmm I do not get it to play sound unless there is an error.. then it is a "boing " sound.
Also the progressbar is not stuck for me.

So are you doing some special copy operation that is not just a simple drag and drop a file on a disk to another disk ?

nok32

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Silent move?
« Reply #4 on: October 12, 2021, 05:15:34 »
It does not show the popup or make the noise for Ctrl-X/V moves. But it does for drag/drop between windows. And it didn't do this at all before the recent update. It never says there is an error but it doesn't auto close the popup even though the auto-close option is selected. And it makes the noise regardless of being 100% completed and seemingly no errors. This is just a normal drag/drop between two normal folders like between Download folder and Documents folder. I tried a complete uninstall and reinstall and it still does it on the fresh install.
« Last Edit: October 12, 2021, 05:46:18 by nok32 »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3886
    • View Profile
    • Multi Commander
Re: Silent move?
« Reply #5 on: October 12, 2021, 11:45:35 »
It does not show the popup or make the noise for Ctrl-X/V moves. But it does for drag/drop between windows. And it didn't do this at all before the recent update. It never says there is an error but it doesn't auto close the popup even though the auto-close option is selected. And it makes the noise regardless of being 100% completed and seemingly no errors. This is just a normal drag/drop between two normal folders like between Download folder and Documents folder. I tried a complete uninstall and reinstall and it still does it on the fresh install.

MC do not handle the copy in the case of paste (Ctrl+V) normally. When MC receives Ctrl+V the paste command is sent to Windows to do a paste in a specified folder..
So MC do not handle any copy of that.

I cannot recreate any issue using drag and drop. And there have been no recent changes there so that is strange.

If you copy using the copy shortcut  F5/F2 (depending on setup) so the internal copy process is used. You get the same issue there or only for drag and drop?

You sure there was not an error, even in the logfile (Ctrl+L, FileOperations log), Most of those sounds are because and error happened. (Can be a minor error han did not cause any issue during the filecopy, so you did not get a error dialog. )

nok32

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Silent move?
« Reply #6 on: October 12, 2021, 22:44:26 »
I have it set to use Windows commands, but if I use the F4 copy or F6 move, it works silently. Then if I do the exact same operation with drag/drop it shows the popup progress window and makes a "bling" noise. The log says it is successful both ways. There is also a weird thing where if I drag a file to move it the popup progress window says 100% completed. But then often if I drag/drop the same file back to the original location again the window will say 0% completed, even though there is no error and the file was in fact moved successfully. It also seems to hang for a second longer on the second move. I first tried this with a small file, I was using a pdf of a few MBs. On a large file, like a 10+GB mp4 it will "bling" noise immediately and the log says the move is successful, but the progress will only say 1% completed and just hangs forever like that with a timer countdown that seems meaningless. If I just click "close" on the progress window, the file is undamaged and the move was successful. It is very strange and annoying. The keyboard commands still work silently and smoothly with large files, it is just a drag/drop issue. The issue seems to directly correspond with the most recent update, not sure what else I did that day but I don't think I made any software installations or any other kind of OS changes, etc.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3886
    • View Profile
    • Multi Commander
Re: Silent move?
« Reply #7 on: October 13, 2021, 08:12:51 »

You do not get a progressbar with F4/F6 ? but with DragDrop ?
You get sound with DragDrop and not with F4/F6 ?

That is strange because drag and drop will call the exact same operation that F4/F6 do.
If you move a file on same drives.. It is not copied. it is renamed. and Moved on the same drive directly without have to read/write all the data. so it jumps to 100% directly

Not sure why this happening to you, I cannot recreate anything like that.



nok32

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Silent move?
« Reply #8 on: October 13, 2021, 21:04:17 »
Correct. Very weird.