Author Topic: Go up ".." don't show  (Read 2728 times)

Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Go up ".." don't show
« on: October 24, 2021, 13:48:12 »
Hello again. I'm using Windows 11 and in some folders que command ".." to go up one level folder missing... I put here as question, because I really dont know if is a feature of windows 11, bug or something odd. Is any option to force this ".." in all windows?

Thanks :)

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #1 on: October 24, 2021, 13:52:51 »
I never seen anything like that. And I do not thing it is a Windows 11 thing.

Is there something special with the folder with the missing ".." ?
Is it your own folders or system folders ?


Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Go up ".." don't show
« Reply #2 on: October 24, 2021, 14:44:43 »
It seem that issue occurs in first level after root folder (as show in the attachment photo). If I enter in any folder after first level... ".." sign/command shows again

(In any subfolder is same)

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #3 on: October 24, 2021, 14:58:40 »
Is it only your Z: drive ? Is that some special network device ? something special with it? When MC scan the filesystem it should returns a ".." item, For normal filesystem MC do not add a the ".." item it self. It should be provided by the filesystem. MC only added it for virtual folders.
So something is different with your Z: then a normal filesystem.

Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Go up ".." don't show
« Reply #4 on: October 24, 2021, 15:20:15 »
Z: is my game physical disk (just change letter).
This happen in any folder, any disk, created by me or creater by windows intallation. ".." dissapear in fist level folder (I don't know if this is correct terminology...I refer at fist folder after root)

I already check for my Windows 10's multi commander, and show ".." in the same leves that win11 don't.

For normal filesystem MC do not add a the ".." item it self. It should be provided by the filesystem.
For that I thought that is a win11 issue (maybe new version of file explorer)

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #5 on: October 24, 2021, 15:27:41 »
Z: is my game physical disk (just change letter).
This happen in any folder, any disk, created by me or creater by windows intallation. ".." dissapear in fist level folder (I don't know if this is correct terminology...I refer at fist folder after root)

I already check for my Windows 10's multi commander, and show ".." in the same leves that win11 don't.

For normal filesystem MC do not add a the ".." item it self. It should be provided by the filesystem.
For that I thought that is a win11 issue (maybe new version of file explorer)

Don't think it is Win11. also MC is not built on top of Windows File Explorer.
I don't know why that is happening for you.. Never seen that happen.
It is not that the ".." folder has hide attribute set ? and your MC is not set to show Hidden/System files ?

Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Go up ".." don't show
« Reply #6 on: October 24, 2021, 15:42:29 »
I check what you said and effectly it's hide ".." in first level folder

UPDATE: I uninstall MC erasing all personal configuration, reinstall with vanilla config and present same ".." hiding/dissapear issue (thinking that is my fault)
« Last Edit: October 24, 2021, 16:08:30 by Tetsuya_Tsurugi »

AlanJB

  • Power Member
  • ****
  • Posts: 379
  • VERY old Programmer
    • View Profile
Re: Go up ".." don't show
« Reply #7 on: October 25, 2021, 00:40:53 »
What kind of drive is Z: - an SSD; an HDD; a VM drive; a subst drive; a USB pen drive; a NAS drive; an SD card; a mounted ISO image?  Something else?

[..] represents the parent of ANY subfolder in ALL windows operating systems since Windows 1.1.  Only a drive "root" (A:, B:, C:, ... Z:) will not have a [..] parent.

Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Go up ".." don't show
« Reply #8 on: October 25, 2021, 01:32:14 »
What kind of drive is Z: - an SSD; an HDD; a VM drive; a subst drive; a USB pen drive; a NAS drive; an SD card; a mounted ISO image?  Something else?
physical HDD, but it happen in any disk, even C:\ (c: its SSD). But it's problem with MC because in my notebook in win10 "[..]" shows normaly

[..] represents the parent of ANY subfolder in ALL windows operating systems since Windows 1.1.  Only a drive "root" (A:, B:, C:, ... Z:) will not have a [..] parent.
I  know, but ".." dissapear only in first leves folders (root's folder). Later, I learn that the ".." appears with hide files and folder

AlanJB

  • Power Member
  • ****
  • Posts: 379
  • VERY old Programmer
    • View Profile
Re: Go up ".." don't show
« Reply #9 on: October 25, 2021, 16:01:48 »
I cannot reproduce this even when I sort folders/files by Ext (as you do).

What version of MC are you using and is it Installed or Portable?

Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Go up ".." don't show
« Reply #10 on: October 25, 2021, 16:12:04 »
I cannot reproduce this even when I sort folders/files by Ext (as you do).

What version of MC are you using and is it Installed or Portable?


Now I'm using version 11.4.2831 (lastest), but win I instal Windows 11 (version Windows 11 pro 21H2 22000.282) with MC version 11.2.0.2795 (Upgrading first and fresh install later after fist time I see the problem).

Oh...btw... I use installed version

UPDATE: I uninstalled MC again and reinstall it with no custom options...same issue (image attached)

UPDATE2: In aaa picture I show you that [..] symbol appaers but If select "show hide files and folders"
« Last Edit: October 25, 2021, 16:22:16 by Tetsuya_Tsurugi »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #11 on: October 25, 2021, 17:50:09 »
I cannot reproduce this even when I sort folders/files by Ext (as you do).

What version of MC are you using and is it Installed or Portable?


Now I'm using version 11.4.2831 (lastest), but win I instal Windows 11 (version Windows 11 pro 21H2 22000.282) with MC version 11.2.0.2795 (Upgrading first and fresh install later after fist time I see the problem).

Oh...btw... I use installed version

UPDATE: I uninstalled MC again and reinstall it with no custom options...same issue (image attached)

UPDATE2: In aaa picture I show you that [..] symbol appaers but If select "show hide files and folders"

Then the ".." folder has the HIDDEN file attrbiute set, Normally you are not able to change file attributes of the ".." folder so not sure how that have happend.

Tetsuya_Tsurugi

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Go up ".." don't show
« Reply #12 on: October 25, 2021, 19:34:08 »
I don't know if is related, but I install other couple of software similar to MC for testing and don't have this issue. (Maybe is not relevant info)

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #13 on: October 25, 2021, 20:32:45 »
MC respect the hidden attribute,  think is that for ".." maybe it should not. Not sure

Question is how you where able to set the ".." to hidden, since it points to the root.
« Last Edit: October 25, 2021, 20:35:06 by Mathias (Author) »

AlexSY

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Go up ".." don't show
« Reply #14 on: October 25, 2021, 21:17:25 »
OS: Windows 11
I have the same issue on all NTFS drives, except USB pen drive with FAT32.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #15 on: October 25, 2021, 22:19:22 »
Remove hidden attribute from the root and it will work.
How you set hidden attribute to the root to begin with I dont know.

AlexSY

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Go up ".." don't show
« Reply #16 on: October 26, 2021, 20:47:48 »
In windows 7, I formatted the USB pen drive (NTFS) and installed MC Portable.
MC showed attributes "----d" for ".." (1.png)

after, I opened the USB pen drive in windows 11 (2.png)

clicked "show hide files and folders" (3.png)
MC showed attributes "--hsd".

after that I reopened the USB pen drive in Windows 7.
MC showed attributes "----d".

I didn't set any attributes.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #17 on: October 27, 2021, 07:21:48 »
Something must change it or something you have hook it self into windows and change the information that MC receives. OR some settings in Windows 11 do it.
I don't know. But I cant replicate it on my windows 11.

AlexSY

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Go up ".." don't show
« Reply #18 on: October 27, 2021, 12:00:30 »
I downloaded the Windows 11 ISO file and did a clean install.

martan1981

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Go up ".." don't show
« Reply #19 on: November 01, 2021, 11:05:48 »
I have exactly the same problem. It must be something with windows 11. After update, cant see [..] in first level folders. Could you please update it, so it does not respect the hidden folder [..]?

Vasencheg

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Go up ".." don't show
« Reply #20 on: November 16, 2021, 08:58:36 »
I have the same issue.
System info:
Windows 11 22000.318.
MC (x64) v11.4 (build 2831)

The issue appears on windows 11.

MBJunior

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Go up ".." don't show
« Reply #21 on: November 27, 2021, 19:44:25 »
I have exactly the same problem after updating windows 10 to windows 11.
What is strange, is that only the [..] directory has a hidden attribute set. The parent directory has normal attribute settings.
It only appears in top-level folders.

This may be related to WSL so that the OS hides the drive letter, but I don't have an option to check it.

Best
MB
« Last Edit: November 27, 2021, 20:23:50 by MBJunior »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3925
    • View Profile
    • Multi Commander
Re: Go up ".." don't show
« Reply #22 on: November 28, 2021, 17:54:34 »
I have exactly the same problem. It must be something with windows 11. After update, cant see [..] in first level folders. Could you please update it, so it does not respect the hidden folder [..]?
try the current 11.5 beta

Vasencheg

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Go up ".." don't show
« Reply #23 on: November 29, 2021, 07:52:14 »
try the current 11.5 beta
Good job! It's all fine. I go back to my favorite file manager. Thank you!