Multi Commander > Script

Problems with MC.FileSearch.Search


I've been using multicommander for now more than a year.
It's a fantastic tool.
But in a script I'm facing a problem with filesearch:
 I wrote a script to "normalize" the directory names on a server.
To extract all the subdirectories names from a directory I try to use sth MC.FileSearch.Search function.
But when I run the script, nothing happens.
As far as i understand, it should return its results in RES: Or eventually an array if assigned to.
I've tried the example syntax seen in the documentation.
But nope !
What is the exact syntax in the script language ?
I use the V12.1 Build 2906 on windows 10.
Thanks For you help.

Mathias (Author):
MC.FileSearch.Search currently not working.. Since search feature was rebuilt to use virtual devices like RESx: for result, the scripting does not work anymore.
But it is high up on the list of my to fix list.

However MC.FileSearch.Search will never return a list to you, it is just a scriptable way to start the search with a set rule of rules.

For low level access you need to use MultiScript functions and there is no direct search support there..
but you can enumerate files and get file info and such. so you can build you own search script for simple search that get a list of matches that you den do something with in the script.

Hello Mathias
Thanks for your quick answer.
I will try another way.


[0] Message Index

Go to full version