Author Topic: I can no longer move from a child directory into it's parent...  (Read 5657 times)


  • Newbie
  • *
  • Posts: 4
    • View Profile
Hi Mathias.
    I've been using MC for a while now, and I love it. Well done!

But I obviously wouldn't be posting to this forum unless I had an issue. I recently had an HDD die on me and decided to upgrade all to SDD and NVMe. Note that this wasn't overnight, but over a few months. I mention it not because I think it's relevant to my issue, but only for transparency, and I'm not ruling anything out anymore, event the phase of the moon. /shrug

After being up and running in all this newer hardware for several months I noticed a few days ago that double-clicking on the parent directory dots, "..", stopped taking me to the parent directory, but only if the parent is the root of the drive. To clarify, if my current working directory is, say "C:\home\bob\junk", dbl-clk on ".." takes me to "C:\home\bob", another dbl-clk on ".." takes me to "C:\home". Finally, whe I dbl-clk on ".." once more...I am immediatly, and without fail taken to "<multi-commander-install-dir>". Every time. No matter where my context is on the drive, trying to use ".." to get to the root always takes me to "<multi-commander-install-dir>".

This happens if I use the mouse, or if I navigate using the keyboard. "pg-up" until ".." is in the input focus, hit enter to go to root...bam!: "<multi-commander-install-dir>".

Now this is new, recent behavior. I have been using these navigation techniques wit MC for years without issue. No other file manager (I've tried 4) is having such an issue. To rule out a strange coincidence of configuration settings or script or macro collisions I downloaded and installed a fresh, clean install of MC. Same thing right out of the box.

Also It doesn't matter which volume is mounted where as which drive letter or mounted directory, same outcome. I have exhausted those combinations as well as destroyed the existing volumes, and recreated. Also the NVMe drive is new this week so no chance to corrupt those volumes in some way.

This is...vexing. I love MC, and I'm working around this for the now, but this is nuts...

I'm stumped. Whatcha' got?   ;D

Windows 10 Pro., Intel 11th gen. processor. 64 G RAM, 2 WD SDD drives and one WD NVMe drive.

Thanks in advance. I can't wait to hear what is causing this...should be a good story to tell...all of those nerd loving chicks...aww...I made myself sadder...


  • VIP Member
  • *****
  • Posts: 433
  • VERY old Programmer
    • View Profile
Re: I can no longer move from a child directory into it's parent...
« Reply #1 on: January 26, 2023, 13:09:18 »

Works for me in MC 11.6 and 12.8.  To clarify, did this start only after your changes of hardware/transport protocols?

Some ideas/WAGs:
Do you actually have access rights to the drive roots?
Do you have any locked tabs?
Are the new drives mounted as shares?


  • Newbie
  • *
  • Posts: 4
    • View Profile
Sorry for the delay. Busy these days...

I had a chance to do a little more testing and the problem appears when MC is executed through a junction, a Windows directory symlink.

Here is what I found:
So imagine the path of the MC executable is in 'C:\usr\share\multicommander-12.8'. So I create a junction in the same parent directory and name it 'C:\usr\share\MC-J'.

Now imagine I execute MultiCommander.exe using the command line 'C:\usr\share\MC-J\MultiCommander.exe'...execute it through the junction.
From that point on, choosing the '..' entry in the directory 'C:\usr' in MC, using the mouse or keyboard, takes me to 'C:\usr\share\MC-J' instead of 'C:\' as it should.

This does not occur if I run MC through it's original path, such as 'C:\usr\share\multicommander-12.8\MultiCommander.exe'. It likewise does not occur if I use a symbolic link instead of a junction, nor does it happen using Windows shortcut files (which are, of course, NOT symlink-like at all). Only through a junction.

I'll leave it up to you to decide if it's worth spending your time on this. I can live with a symlink as my path shortener here. It should be noted however that with the now "sanctioned" use of NTFS symbolic links it could crop up more often. It originally happened to me because the '\usr' directory was on a different partition, forcing the use of a junction to achieve what I wanted with that storage layout. Not quite an edge case, that.

Thanks again for the great program.