Author Topic: Multi Commander - Extension / Plugin System  (Read 4981 times)

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3026
    • View Profile
    • Multi Commander
Multi Commander - Extension / Plugin System
« on: September 01, 2012, 16:17:08 »
Multi Commander is build around extension and plug-ins, almost all tools major features  in Multi Commander comes from an extension.

There are a couple of different types of extension and plugins.

Tools / Utilities Extension
These are extension that can interact with the core system in Multi Commander. They can show a GUI in it's own window or inside a tab.
Extended the script system with more commands, add own command that will be shown in the menu.

Eg. PictureViewer is a extension that shows it's own gui, MultiRename is an extension that is mixing internal gui element inside it's own window and The File Checksum verifier shows it's GUI inside a tab in Multi Commander. FSFTPScript extends the script language with FTP support.

File System Plugins
These are used to allow Multi Commander to browse archives, FTP, Registry and other resources that has a file system like structure.

File Properties Plugins
These are plugin that are used to retrieve file properties on file. For example the Picture Properties plugin allow you to get file properties of picture files so you can show column with picture properties like Image size, EXIF date and a lot more.

File Operations Plugins
These are plugin that are used during copy/move and delete operations. They can modify the target location of the file, Change the data that is read/written or do something after a file operation is completed.

For example the built in plugin "Auto Sort" will change the target location so that if a file called "MyFile.txt" is copied, it will place it under a 'M' subfolder under the selected target location.  And the AutoUnpack plugin will notice if the user are copying a .zip file and will then tell the system to copy the content of that file instead, So that the zip file is automatically unpacked.

SDK

Requirements
You will need to have knowledge of C++ to use the SDK. The included samples needs at least Visual Studio 2015  (vs2017 also works, But plugin will not work on XP then)
(VS2015 Express Desktop Edition should work.)

SDK Download
Download SDK ( v1.73 ) (Last updated 2017-06-25)

« Last Edit: June 25, 2017, 16:16:40 by Mathias (Author) »