Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - darkwit

Pages: [1]
When MultiCommander tries to move or rename a file that is being used by another process, the response is different depending on whether it is being Moved or Renamed.

For moving, it says: (this is a cut&paste of the error dialog text)
Cannot open the file 'MyDocumentFilename.pdf'.
It is being used by another program.
Close any program that might be using the file and try again
Retry   Skip   Skip All   Cancel   

For renaming, it says: (this is a cut&paste of the error dialog text)
Rename of file/folder failed
Unable to rename because of sharing violation.
Another process might be using this file/folder.

Do you want to search for processes that are using the file/folder?
Yes   No   Cancel   

For me, the "Retry" behaviour is far more convenient since I usually know what the offending program is (my PDF reader has the file open while I'm trying to Rename/Move a PDF file), so my wish is for the renaming dialog to also have a simple "Retry" button so I can close the file in the PDF reader and click on "Retry" without having to type in the desired new filename again (which is complex and specific). 

Other people might find it useful to locate the process that is keeping the file open.  But why not have both functionalities in both Move and Rename?  It seems like the required code is already part of MultiCommander, so it just needs to be unified to say something like Retry? Skip? Skip All? Find Process? Cancel?  (the "skip" options don't have to appear on the Rename dialog)

I am not sure I fully understand what OP (Schlaffie), but let me try asking this:

When I want to select a range of files beyond what is visible, I click on the first file to select.  Then, WITHOUT HOLDING DOWN THE MOUSE BUTTON, I scroll down to the last file I want selected.  (By this time, the originally selected file has scroll off the top of the window and is no longer visible.)  I hold down Shift and then click on the last file I want to select.  Multi-Commander selects all the files from the first up to and including the last file.

Does that work for you?  I use a Commander-style interface, not an Explorer-style interface; not sure if that makes a difference.  Possibly it is not what you are used to, and you are looking to do it your way specifically rather than there being a possible way to do it.  But definitely you can mark more files with the mouse than are visible in the window.

Hope that helps!

Thank you for your prompt and detailed response!  It makes me appreciate Multi-Commander all the more.

I often use Multi-Commander in a directory of a large number of files (about 50,000 of them).  Multi-Commander keeps rescanning them, which takes a bit of time and is not necessary.  I know when the files change, and am willing to push a key such as F2 or F5 to rescan.

I saw a posting from 2017 on how to turn off AutoRefresh to stop rescanning:
I followed the directions, typing ":AutoRefresh 0", and it seemed to accept.  I see that Multi-Commander scans the folder only about half as often as before.  However, is it possible to disable the refreshing completely and have it only apply manually (or when I first change to a directory)?

When I copy a file in Multi-Commander to the same directory, and there is already an existing file, then I am unable to overwrite the old file even when I want to.  The filename of the destination file is automatically changed to add "(1)" or some other number after the file.

In this particular case, I have different versions of settings that I want to copy onto (overwrite) the default file, something like the files in this simplified example:


A program reads "settings_default.set" to get its settings.  I want to overwrite the "settings_default.set" with one of the other two settings files, depending on how I want to set up the program.
I position the Multi-Commander cursor to select "settings_for_profile1.set", and then press F5 to copy.  For the destination, instead of copy to the other panel by default, in the Copy/Move dialog I replace the destination with "settings_default.set".
The result I would like is that Multi-Commander replaces "settings_default.set" with a copy of "settings_for_profile1.set", possibly popping up a dialog to confirm file overwrite.
The actual result is that a new file is created, "settings_default.set (1)", without asking for a choice of overwrite, skip, keep if newer etc that shows up most of the time.

It appears that this happens when I am copy a file to another name in the same directory.  When I copy to a different directory, shown in the other panel, Multi-Commander correctly asks me whether I want to overwrite.

This is related to, but not the same as, "Issue with copy to existing file" on this forum at,4339.msg12402.html#msg12402
In that posting, it does not say that the problem appears only when the starting and destination directory are the same.

Thank you for any help you can give. 

Hello!  Just to follow-up, I forgot how to set hot paths and again went to :
Again had trouble accessing hot paths, came for help and then realized I had asked the exact same question almost a year ago in this forum:,4116.msg11685.html#msg11685

Thank you for your help.  May I suggest that the web page above be updated to replace the Ctrl-H shortcut with Alt-Backspace?  I'm sure I'm not the only one who was looking for this.

Thank you again for an excellent piece of software.

Thank you for your reply, which I read some time ago but didn't have a chance to reply to thank you.

I ended up choosing MultiCommander, which is impressively full-featured, as my file manager.


I am evaluating MultiCommander as a replacement for Servant Salamander (now that I'm upgrading to an up-to-date version of Windows), and read with delight that I can set my own hotkeys for paths: Ctrl-1 to jump to some directory that I like, or Ctrl-2 for another one.  I'm supposed to be able to set these with Ctrl-H.  It says right there in

But nothing happens when I press Ctrl-1, or Ctrl-H. 

Not only that, but under Configuration > Keyboard Customization, I don't even see the Ctrl-1 or Ctrl-H shortcuts, even though I see a whole host of other shortcuts.

Is there some checkbox I need to check, like "Use the REAL MultiCommander" or something?  I am using the Portable version of MultiCommander -- does this make a difference?  I am using v10.1 (Build 2743), which I hope is current because I just downloaded this last week.

Web searches for the answers to my query just keep turning up variations on the above information, with no clue as to why it's not working in my particular case.

Any help would be gratefully appreciated.

Pages: [1]