Recent Posts

Pages: [1] 2 3 ... 10
1
Script / Re: Copy and convert audio. Can I do this as a script?
« Last post by force_redo on November 18, 2017, 20:05:48 »
Hi Reset,

it was an old post, but I hadn't solved it myself yet. With your help and a bit of copy & paste I came up with this now, which does the trick for the selected files in the current directory. No idea how this would work with recursive subdirectories, but this does the trick for now:

Code: [Select]
@var $arr = GetSourceSelectedPaths();
@var $items = arrayCount($arr);
@var $path = GetTargetPath();

@var $SourceFile
@var $s
@var $name

@var $n = 0;

//loop

for( $n = 0; $n < $items; $n++ )
{
  $SourceFile = $arr[ $n ];
  $name = PathGetNamePart($SourceFile, 1);
  $s =' -i ' + '"' + $SourceFile + '" ' + '-map a "' + $path + $name + '.mp3"';
  MC.Run CMD="C:\Program Files\ffmpeg\bin\ffmpeg.exe" ARG="{$s}"

}

P.S.: What is the difference between GetSelectedPaths and GetSourceSelectedPaths? The documentation says:
"An array of the complete paths for all the selected files and folders in the source view" for one
and
"Get an array with the full paths of all selected items in the source view" for the other.

Thanks again!
2
Support and Feedback / Re: Settings Not Saving
« Last post by DiggerP on November 18, 2017, 03:54:33 »
@ My711thLoginHandle,

Hi,
Have you tried to address this using Windows setttings via Notification (Systray) Settings?
Right-click the ^ (Up) arrow ( Show hidden icons)  and choose Settings - Then go to Notification area - Then  "Select which items appear on the Taskbar."

If those settings don't hold, it's Windows that doesn't save your settings, not a fault of MC...
3
Support and Feedback / Re: Settings Not Saving
« Last post by My711thLoginHandle on November 16, 2017, 15:25:37 »
So far everything else I have changed saved.
Even though it is a fresh install on a new laptop, I could try deleting the settings completely and try again.
It is not that big of an issue if I see it. More of an OCD thing really, and a couple of decades of keeping a tidy taskbar.
I will play around more and if I figure anything I will reply back. Not going to make this a huge deal.
4
Beta Releases / Re: Multi Commander v7.6 BETA
« Last post by Mathias (Author) on November 16, 2017, 13:15:41 »
Mi Mathias.

I notice the new beta is not showing the "Beta" banner on the splash screen or the "About...." screen.

Opss I forgot to activate that flag hehe
5
Beta Releases / Re: Multi Commander v7.6 BETA
« Last post by AlanJB on November 16, 2017, 11:17:12 »
Mi Mathias.

I notice the new beta is not showing the "Beta" banner on the splash screen or the "About...." screen.
6
Support and Feedback / Re: Settings Not Saving
« Last post by Mathias (Author) on November 15, 2017, 22:16:06 »
Strange.

If the settings is off.. MC will not tell windows to add a tray icon..Maybe the settings is not save ?
Do it keep other settings ?
7
Support and Feedback / Re: Settings Not Saving
« Last post by My711thLoginHandle on November 15, 2017, 21:24:25 »
Yes. Seems to be coming back after rebooting and starting the program.
8
Support and Feedback / Can't copy files to or from portable device
« Last post by Tom L on November 15, 2017, 19:20:20 »
I drag a file that is visible on the Explorer Panel of a portable device (phone, which is attached via USV port to my pc) to my pc's desktop or other folder, but nothing happens.  I can see the gray rectangle icon with the gray file name and the plus sign (for copy) move along as I drag, but when I release the mouse button, the file I'm trying to copy doesn't appear in the destination. OR if I try to move a file on portable device somewhere else on the portable device I get two error messages as in attachment.

When I do the same thing using Windows File Explorer (Win 8.1) it copies in either direction with no problem.
9
Support and Feedback / Re: Settings Not Saving
« Last post by My711thLoginHandle on November 15, 2017, 15:41:20 »
The icon popped back up after the weekend.
I wonder if related to reboots. I will do some testing.
10
Beta Releases / Multi Commander v7.6 BETA
« Last post by Mathias (Author) on November 14, 2017, 19:21:28 »
Release v7.6 BETA

I'm been so very very very busy. So I had not had time to add everything I had planned.
But here are some fixed anyway

73+ Changes


-- Build 2391 - (15-Nov-2017 )
 FIXED - Fixed crash issue with range selection
 FIXED - Wrong thumbnail was shown for target file
 FIXED - Crash if dialog was shown for file inside archive.. No crash anymore. but info shown in empty for now

-- Build 2390 - (14-Nov-2017 )
 ADDED - NEW Conflict dialog when copy/move files and file already exists. The new window have support for thumbnails are more options (And more will be added to it)
 ADDED - Settings if FocusItem should be saved on exit or not
 ADDED - MultiDataFileViewer got more default setups (thanks to pncdaspropagandas )
 ADDED - Added workaround for issue that if network mounted device got unmounted and remounted it got the same name since Windows Cached it.
 FIXED - Issue with range selection in WinExplorer setup
 FIXED - Issue with tab stealing focus when MultiRename window closes
 FIXED - 3 Stability issue reported by crash report system
Pages: [1] 2 3 ... 10