Author Topic: MC 5.5.1 build 1980 failed to read config file  (Read 12697 times)

Timon

  • Junior Member
  • **
  • Posts: 34
    • View Profile
MC 5.5.1 build 1980 failed to read config file
« on: August 18, 2015, 19:55:27 »
After update to current beta version 5.5.1 build 1980 from previous beta (maximum 7 days have passed since previous update, it worked without any problems) I see error messages:
Failed to open or read config file: C:\Program Files\MultiCommander\Config\MultiCommander.xml
It might be corrupt try to replace it with a backup or delete it.

Failed to open or read config file: C:\Documents and Seiings\<Profile name>\Application Data\MultiCommander\Config\MultiCommander.xml
It might be corrupt try to replace it with a backup or delete it.

Both messages are shown several times.

Tried to pack xml files and deleted both MultiCommander.xml files, but problem is still present.

OS Microsoft Windows XP SP3

P.S. By the way, comma is missing (after word corrupt) in English version of error message - It might be corrupt, try to replace it with a backup or delete it.
« Last Edit: August 18, 2015, 20:42:39 by Timon »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #1 on: August 18, 2015, 22:27:45 »
Either the file is not a valid xml file..(something have modified it)
or you do not have permission to read it
or something is blocking MC from reading it  (AV/Security software/Sandboxing)

The file in "program files" are used as a template and a personal config file is save under user profile.

Yes the message is shown everytime it tries to load a config file and fails.

You should not pack xml files.. they are text files and need to be that. Packing them will corrupt them
And you should not delete the file under program files since that is the "default" file, That file is never change. it is the template for when creating the user config file.

Timon

  • Junior Member
  • **
  • Posts: 34
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #2 on: August 19, 2015, 12:57:33 »
Quote
Either the file is not a valid xml file..(something have modified it)
or you do not have permission to read it
or something is blocking MC from reading it  (AV/Security software/Sandboxing)

But previous version worked without any problems! Update "killed" MC

Quote
You should not pack xml files.. they are text files and need to be that. Packing them will corrupt them
I packed file to have ability to restore them if deleting would not solve the problem.

Quote
And you should not delete the file under program files since that is the "default" file, That file is never change.

But MC suggests to delete that files! You have to change warning messages.

I have one more computer running version 5.5 build 1975. I updated it today, and got the same problem. App worked till update. Now it says the same and couldn't start.
It was absolutely different PC with different config and different apps installed. Only OS was the same - Windows XP SP3.
Thanks God I made a backup. I restored previous version from backup (5.5 build 1975) and all works again without any problems!

So it is MC problem.
« Last Edit: August 19, 2015, 13:04:37 by Timon »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #3 on: August 19, 2015, 13:15:28 »
Quote
Either the file is not a valid xml file..(something have modified it)
or you do not have permission to read it
or something is blocking MC from reading it  (AV/Security software/Sandboxing)

But previous version worked without any problems! Update "killed" MC
No the update do not even change the config file. So something else must have done something.


Quote
You should not pack xml files.. they are text files and need to be that. Packing them will corrupt them
I packed file to have ability to restore them if deleting would not solve the problem.
Fine as long as you unpack when your restore them


Quote
And you should not delete the file under program files since that is the "default" file, That file is never change.

But MC suggests to delete that files! You have to change warning messages.
If the file is delete it will generate a new one. if it can.


I have one more computer running version 5.5 build 1975. I updated it today, and got the same problem. App worked till update. Now it says the same and couldn't start.
It was absolutely different PC with different config and different apps installed. Only OS was the same - Windows XP SP3.
Thanks God I made a backup. I restored previous version from backup (5.5 build 1975) and all works again without any problems!

So it is MC problem.
Sorry. I do not think so, upgrade is replacing some files but not the config file. And if that was an issue everyone should have and issue and not only you
Question is why this is only happening to you. What is unique with your setup ?
The problem is because either the file is corrupt or something is blocking MC from reading it.
You can validate a xml file If you open the xml file in IE, it will complain with an error if the xml file is not formatted correct.
The other is if something is blocking MC. and that can be AV/Sandboxing or other security software.

Timon

  • Junior Member
  • **
  • Posts: 34
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #4 on: August 19, 2015, 15:28:57 »
Are you sure, that MC is right with problem detection?

I made one more update and restore to understand what's the problem.

I must say, that C:\Documents and Seiings\<Profile name>\Application Data\MultiCommander\Config\MultiCommander.xml has no problem at all!
I just restored data in Program Files and everything works fine.

Then I desided to change only 1 file - MultiCommander.exe to latest version and app stopped working with the same error messages! All other files were from the old version.

Once you already made non working update for Windows XP after Visual C++ update. May be problem is similar... And I don't see any messages from my AV software and nobody could change content of xml files because nobody changed them. I restored MultiCommander.exe from previous version (5.5 build 1975) and MC works again! It's a miracle! So the problem is with 1 file - new MultiCommander.exe under Windows XP SP3.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #5 on: August 19, 2015, 15:52:27 »
Are you sure, that MC is right with problem detection?
The error message is because it fails to read the config file. and the failure can only be because of a very few reason.

I made one more update and restore to understand what's the problem.

I must say, that C:\Documents and Seiings\<Profile name>\Application Data\MultiCommander\Config\MultiCommander.xml has no problem at all!
I just restored data in Program Files and everything works fine.
If it can read the file in userprofile folder, the file in program files is not used.
the file under program files is only used if it does not find one under profile.

Then I desided to change only 1 file - MultiCommander.exe to latest version and app stopped working with the same error messages! All other files were from the old version.
It works for me, Something is very strange with your system. It should start, However with limited features since all the plugins dlls are from old mismatched versions so they will not load. I would almost guess that AV or something is blocking MC from doing stuff until they are done with it.

Once you already made non working update for Windows XP after Visual C++ update. May be problem is similar... And I don't see any messages from my AV software and nobody could change content of xml files because nobody changed them. I restored MultiCommander.exe from previous version (5.5 build 1975) and MC works again! It's a miracle! So the problem is with 1 file - new MultiCommander.exe under Windows XP SP3.
No. If the program would not work on XP it would not even start. And it would not start to work after replacing the file. It will be the same all the time.




Jungle

  • Contributor
  • VIP Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #6 on: August 19, 2015, 19:13:11 »
I think i've found out what causes this error in new versions.

In a few words...
1. Config file date. It should be "valid". E.g. if you change year to 1614 error will occur.
2. Config file owner. My MC folder (with subs) owner was 'Unknown', i changed it to current user and error has gone.

So, Mathias, something definitely has changed, because 5.5.0.1967 RC and below work fine, while newer don't.
« Last Edit: August 19, 2015, 19:16:19 by Jungle »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #7 on: August 19, 2015, 19:45:30 »
The strange thing is that the updater is not even copying in a new config file. so How the file date of that file can change is very strange.
And the updater does not even change owner or any NTFS security things.
There is no logic in why this should happen.. if this is some weird XP issue then there is nothing I can do. I do have any XP systems anymore.

Not sure how you can have "unknown" as owner. that is wierd. It explains reading error since the program will not be allowed to read the file.


Timon

  • Junior Member
  • **
  • Posts: 34
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #8 on: August 19, 2015, 20:11:26 »
Nothing helps me to solve the problem.

I was the owner of all files, but I forced update of user rights to all MultiCommander folders incliding subfolders for Program Files and Documents and Settings.
Also changed date for all folders to current. But it also could not solve the problem.

Quote
Something is very strange with your system
I could agree, if the problem was on only one computer, but it occurs on different systems with different apps installed.

It would bad if MC could no longer support Windows XP.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #9 on: August 19, 2015, 20:17:50 »
I think i've found out what causes this error in new versions.

In a few words...
1. Config file date. It should be "valid". E.g. if you change year to 1614 error will occur.
2. Config file owner. My MC folder (with subs) owner was 'Unknown', i changed it to current user and error has gone.

So, Mathias, something definitely has changed, because 5.5.0.1967 RC and below work fine, while newer don't.
And version 5.5.0.1975 does not ?  (5.5.0 Final)  they are both still built with VS2013. Only big change is compiler and that is only for the 5.5.1 beta
But I don't see how change of compiler can cause this.

Btw what file(s) date was changed ?  the Config/ folder or its content..  Under userprofile or Program files ?

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #10 on: August 19, 2015, 20:22:05 »
Nothing helps me to solve the problem.

I was the owner of all files, but I forced update of user rights to all MultiCommander folders incliding subfolders for Program Files and Documents and Settings.
Also changed date for all folders to current. But it also could not solve the problem.

Quote
Something is very strange with your system
I could agree, if the problem was on only one computer, but it occurs on different systems with different apps installed.

It would bad if MC could no longer support Windows XP.
I don't think it is a XP issue..There is no logic in it.
When going from 5.5.0 to 5.5.1 beta. The updater is still the old one. There is no new feature release of MultiUpdate so it does no forced update if it first.
So it is actually still the MultiUpdate.exe from 5.5.0 that does the update and that is still built with VS2013.
And that makes the issue even stranger.

Jungle

  • Contributor
  • VIP Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #11 on: August 19, 2015, 21:14:28 »
And version 5.5.0.1975 does not ?  (5.5.0 Final)  they are both still built with VS2013. Only big change is compiler and that is only for the 5.5.1 beta
But I don't see how change of compiler can cause this.

Btw what file(s) date was changed ?  the Config/ folder or its content..  Under userprofile or Program files ?
5.5 final probably works ok but i've replaced exe with 5.5.1, will check later
I had the problem with Aliases.xml in the Config folder of MC portable. If i change year to e.g. 2015, MC starts ok. If i change it to 1614, error occurs. Haven't tried other xml files, but i think that result will be the same

P.S. It's on Win 7 Pro

Jungle

  • Contributor
  • VIP Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #12 on: August 20, 2015, 06:10:46 »
Yes, 5.5 final is OK.

BTW, error message is hidden behind splash. It is only partly visible with default Windows 7 UI, but with classic theme it can't be seen so MC looks frozen

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3814
    • View Profile
    • Multi Commander
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #13 on: August 20, 2015, 08:28:29 »
And version 5.5.0.1975 does not ?  (5.5.0 Final)  they are both still built with VS2013. Only big change is compiler and that is only for the 5.5.1 beta
But I don't see how change of compiler can cause this.

Btw what file(s) date was changed ?  the Config/ folder or its content..  Under userprofile or Program files ?
5.5 final probably works ok but i've replaced exe with 5.5.1, will check later
I had the problem with Aliases.xml in the Config folder of MC portable. If i change year to e.g. 2015, MC starts ok. If i change it to 1614, error occurs. Haven't tried other xml files, but i think that result will be the same

P.S. It's on Win 7 Pro

Found why file date mess things up..
File date failure is because Microsoft have broke a the standard C Lib function (stat) in VS2015 that many MultiPlatform libraries are using for checking if file exists.
(Wrong way of doing that. But can be used like that, But the std C lib way to get file stat does not support dates beyond 1970. and that makes that function fail.)
This will be probably be fixed with next update for VS2015. and it can be worked around

But that does not explain why the file date are messed up to begin with.

Timon

  • Junior Member
  • **
  • Posts: 34
    • View Profile
Re: MC 5.5.1 build 1980 failed to read config file
« Reply #14 on: October 25, 2015, 18:19:45 »
Desided to make update from build 1975 to MC 5.6.1 build 2021 and I see no more that problem! It works fine in Windows XP SP3. Several times before I tried update to previous beta versions and MC refused to work. So problem is fixed now (hope, forever).