Multi Commander > Support and Feedback

MC Crashes after changing to D:

(1/2) > >>

On my primary system i've installed MC on C: and all works ok.

When selecting "D:" for either one panel MC crashes after 1 second (or when "D:" is started initially),
creating a crash-report.  This report is send to MC but no answer yet.....

This does NOT happen on my other system(s) or when changing to another drive (like E:) .
Also, when running in Admin-mode the crash does not occur.

Anyone knows what happens or how to fix this?



Mathias (Author):
Thats strange.

What version/build are you running ?

Are they anything special with D:  (network mounted ? , usb drive ?, cdrom ? )

I will check the crash dump and see if it says anything.

Hi Mathias.

Thanx for your reply. First of all congratulations on a great product. Keep adding options and features and you got a winner.

On the "D:" problem:
ITs a regular second partition on a regular internal disk, nothing fancy. Windows-7, "PRO". I got the latest build (1.1.1) and even tried the latest beta: same result. I also copied the full dir + config + user-config + registry-entries from my other system (which runs OK) and again got the error.
Also : did a disk check, reset the security (full) and tried several settings of MC (disabled).
If you need more info, please use my email.


Mathias (Author):
Did it send a crash report ? I'm not able to find one that matches your problem.

Since the crash is not immediately. You say it comes after a second after you changed drive. My guess is that something with the process of getting the file icons that makes it crash. Can you try to disable icons just to verify if that can be the problem?

Menu > Configuration > Explorer Panel Settings > Layout(tab) > Icons (group)  (uncheck everything there)

You are right. Problem disappeared when disabeling the icons.

So I tested each setting individually and the "icon overlay" setting created the problem.

There is a special icon on my "Dropbox" directory, defined by Dropbox,
which is shown in Explorer and TC (...) and not in MC. Could this be the problem?

I removed all files from the root of D: so it MUST be a directory ....



[0] Message Index

[#] Next page

Go to full version