Author Topic: After the update, I can't even launch MultiCommander 12.0.0.2877 under Windows 7  (Read 670 times)

Timon

  • Junior Member
  • **
  • Posts: 40
    • View Profile
Windows 7 Pro 32-bit. Updated to 12.0.0.2877. After the update, I can't even launch MultiCommander.
Crash-IDs: 12-X119HS and 12-B119UE
If you need any additional info, ready to send.

Before that, repeatedly updated and didn't experience any problems with the operation or app launch

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
(Move topic to Beta section, since v12 is only out as beta..)

According to the crashdump it is when trying to read the language file. I can't see exactly what since the minimum crashdump does not contain any data.
The crash location is very strange and should not even be possible to happen.
Maybe <appfolder>\Languages\MC_LangPack_en.zip got corrupted ? can you open that file with Windows Exporer ?


Timon

  • Junior Member
  • **
  • Posts: 40
    • View Profile
Yes. I can open MC_LangPack_en.zip and MC_LangPack_ru.zip files with Windows Exporer. I even checked the archives for integrity in Winrar 6.11 and 7-zip 21.07 and 22.00- No errors found. Can I provide any additional information to solve the problem?
« Last Edit: June 20, 2022, 13:36:12 by Timon »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
You can try to install the Microsoft VC Redist 14.32
https://docs.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170

It should be built into the exe, but Windows 7 is weird. and might require as a side by side install.


Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
Yes. I can open MC_LangPack_en.zip and MC_LangPack_ru.zip files with Windows Exporer. I even checked the archives for integrity in Winrar 6.11 and 7-zip 21.07 and 22.00- No errors found. Can I provide any additional information to solve the problem?
Also are you running Windows 7 or Windows 7 SP1 ?

Timon

  • Junior Member
  • **
  • Posts: 40
    • View Profile
I'm running Windows 7 SP1.

Already had in my system:
- Microsoft Visual C++ Redist 2008 9.0.30729.6161
- Microsoft Visual C++ Redist 2010 10.0.40219
- Microsoft Visual C++ Redist 2015-2022 14.31.31103

Updated to Microsoft Visual C++ Redist 2015-2022 14.32.31326. Rebooted the computer. But nothing helped. Crash-ID: 12-L120AF

« Last Edit: June 20, 2022, 22:30:12 by Timon »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
I'm running Windows 7 SP1.

Already had in my system:
- Microsoft Visual C++ 2008 9.0.30729.6161
- Microsoft Visual C++ 2010 10.0.30319
- Microsoft Visual C++ 2015-2022 14.31.31103

Updated to Microsoft Visual C++ 2015-2022 14.32.31326. Rebooted the computer. But nothing helped. Crash-ID: 12-L120AF

Are you really sure it is SP1 ?
Because the crash is in the new unzip code. The new unzip code uses AVX2 CPU instruction for faster performance (If the CPU supports it).
But AVX2 CPU instruction also require OS support and that was not added until Windows 7 SP1. So that would explain the crash.
Not sure if the AVX2 support is something that can be turned off someplace in the OS.

I have it running on a clean Windows 7 Sp1 on a virtual machine.. I don't have one without Win7. can't install that anymore

Edit
you have not by any chance modified the boot kernal parameters and have run

"bcdedit /set xsavedisable 1"  ?

That would disable the OS support for AVX2.  so doing "bcdedit /set xsavedisable 0" should enable it again..



« Last Edit: June 20, 2022, 22:43:56 by Mathias (Author) »

Timon

  • Junior Member
  • **
  • Posts: 40
    • View Profile
Yes, I'm sure (see screenshot) https://ibb.co/ftxHxqB

Edit
Tried to run
bcdedit /set xsavedisable 0
But the system reported:
"The boot configuration data cannot be opened.
Access denied."
Despite the fact that I am an Administrator

Edit2
Run cmd as Administator
bcdedit /set xsavedisable 0
Operation completed successfully
But again that not helped. Crash-ID: 12-C120RV
« Last Edit: June 20, 2022, 23:25:42 by Timon »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
Strange, because the crash is that the AVX2 cpu instructions is not allowed. 

Timon

  • Junior Member
  • **
  • Posts: 40
    • View Profile
Updated to version 12.0.0.2885 - again crash.

From http://multicommander.com/downloads downloaded MultiCommander v11.6.0 (Build 2845) (32 bit) SHA1 : 1046D81971C39856698629AABB9505040A5A0745 and made "Upgrade", which is actually "Downgrade". And it works fine at the samу notebook without any additional actions on my part! Now I'm afraid to upgrade to a fresh beta. In the new versions, something is clearly broken on your side, otherwise the old version would not work either. How else can I help to solve this problem?

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
Updated to version 12.0.0.2885 - again crash.

From http://multicommander.com/downloads downloaded MultiCommander v11.6.0 (Build 2845) (32 bit) SHA1 : 1046D81971C39856698629AABB9505040A5A0745 and made "Upgrade", which is actually "Downgrade". And it works fine at the samу notebook without any additional actions on my part! Now I'm afraid to upgrade to a fresh beta. In the new versions, something is clearly broken on your side, otherwise the old version would not work either. How else can I help to solve this problem?

Im not able to reproduce that.  I tried on a Clean Win 7 SP1 and it worked.
If the crash is same as before it is becuse CPU do not like AVX2 instruction, and that is strange.

What CPU do you have ? (you can type :sysinfo in the command field in mc to get that )
The unzip code that used AVX2 is checking if the cpu support that. so it should not matter.. But maybe there are some CPU version that are reporting wrong or something.

If the crash happens again after next beta  .. not 2886 but after 2887+ then send a crash dump again, becuse since I can't make it crash I have nothing to go on.
Also before you upgrade if you can change crash dump settings to in "Core settings > Misc " to Medium or Max. That would give me more information to go on. The dumps right now dont give much more clues on what happend.
« Last Edit: July 05, 2022, 22:44:45 by Mathias (Author) »

Timon

  • Junior Member
  • **
  • Posts: 40
    • View Profile
CPU Information
-------------------
Intel(R) Atom(TM) CPU Z550   @ 2.00GHz
x86 Family 6 Model 28 Stepping 2
GenuineIntel
Speed : 1999 MHz
1 Cores ( 2 Threads )

Updated version 11.6.0.2845 to beta version 12.0.0.2888 and it works fine, thanks. I just don't understand what was wrong before. In any case, changed crash dump settings to Max if something like this happens again in the future

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 4004
    • View Profile
    • Multi Commander
Nice.. Good that it works now... Then the fix for it worked.