Multi Commander > Support and Feedback

Context menu "new" Windows 11 22H2 22621.521

(1/4) > >>

Hi Mathias,

first pic is default Windows Explorer menu, second is MultiCommander menu.
Miss some items for "new"
1. Bitmap
2. Text file

Hint: Clean install of Windows 11 - no upgrade from Windows 10

Mathias (Author):
Hard to say why they do not show up for you. I get them to show up on all my machines.
All 'new items' for the shell context menu are parsed from the registry (HKEY_CLASSES_ROOT) depending on if they have a ShellNew/ entry.. eg   


There is also one other way Apps add a ShellNew item bu adding a reference to default item and then have ShellNew under that..

OK, these items are not available.

What is the correct syntax eg. for .txt?

Windows Registry Editor Version 5.00


For HKEY_CLASSES_ROOT\.txt\ShellNew\:

the Key (type REG_EXPAND_SZ) name is: ItemName

data is : @%SystemRoot%\system32\notepad.exe,-470

Thx for your suggestion.

For HKEY_CLASSES_ROOT\.bmp\ShellNew\

the Key (type REG_EXPAND_SZ) name is: ItemName

data is : @%SystemRoot%\system32\notepad.exe,-470

Unfortunatelly it won't work. Reg keys are available, but still missing in context menu.

Found some forum posts for other file commanders like TC or FreeCommander from users with same problem. In both cases the developers solved the problem.

Hint/TC Changelog: Still no entry for .txt files in Context menu-New submenu on Windows because the key HKEY_CLASSES_ROOT\txtfilelegacy was missing a (default) value = description

I really don't know what this "default value" could be.


[0] Message Index

[#] Next page

Go to full version