Author Topic: Bugs (or misbehaviour) in 3.1.0 b1400  (Read 7739 times)

Jungle

  • Contributor
  • VIP Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Bugs (or misbehaviour) in 3.1.0 b1400
« on: April 26, 2013, 05:32:29 »
1. Since b1379 there are two file cursors - in each file panel

2. Since b1379 hovering (file cursor follows mouse) works for inactive panel too. In earlier builds it worked only in active panel.

3. There is a bug with cursor following mouse pointer (hovering).
 
 a. Set small wait time (20 ms)
 b. Create quicklaunch button which accepts files as parameters (e.g. notepad)
 c. Drop some file(s) to that button
 d. Close application (notepad)
 e. Move mouse to MC but don't click, then move it over files/folders
 
 Result: cursor following for active tab (from which files were dropped) is broken. Wait time is not 20ms.
 
 f. Now click on the Explorer panel.
 g. Move mouse over files/folders
 
 Result: cursor following is restored. Wait time is 20 ms again.

4. Changelog says that SetActiveTab support /PREV /NEXT params, but they are seem to be missing in custom commands
« Last Edit: April 26, 2013, 05:37:20 by Jungle »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3859
    • View Profile
    • Multi Commander
Re: Bugs (or misbehaviour) in 3.1.0 b1400
« Reply #1 on: April 26, 2013, 07:02:45 »
1. Ohh I forgot about this

2. Well It works the same, but because of (1) you did not see it.

3. I know and will not be fixed. It has to do with that focus is not restored until you click something.

4. NO there is no /PREV /NEXT param. but you can set the paramter Tab="..." to PREV/NEXT  TAB="PREV" , TAB="NEXT"

Jungle

  • Contributor
  • VIP Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Re: Bugs (or misbehaviour) in 3.1.0 b1400
« Reply #2 on: April 26, 2013, 07:20:55 »
3. I know and will not be fixed. It has to do with that focus is not restored until you click something.

But it works on the inactive panel. If in e) you move mouse over active panel, following is wrong, but on the inactive panel it keeps working correctly.

Quote
4. NO there is no /PREV /NEXT param. but you can set the paramter Tab="..." to PREV/NEXT  TAB="PREV" , TAB="NEXT"

I was quite inattentive :) But i think this should be mentioned in u.46 line for MultiCommander core

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3859
    • View Profile
    • Multi Commander
Re: Bugs (or misbehaviour) in 3.1.0 b1400
« Reply #3 on: April 26, 2013, 07:27:19 »
I was quite inattentive :) But i think this should be mentioned in u.46 line for MultiCommander core

no but u,47  :)


Jungle

  • Contributor
  • VIP Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Re: Bugs (or misbehaviour) in 3.1.0 b1400
« Reply #4 on: April 26, 2013, 07:32:05 »
no but u,47  :)
Maybe something has changed, but i've modified u.46 :)

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3859
    • View Profile
    • Multi Commander
Re: Bugs (or misbehaviour) in 3.1.0 b1400
« Reply #5 on: April 26, 2013, 07:48:14 »
Yes you are right, I was looking in the wrong place. It is too early in the day.. :)