Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jean

Pages: [1] 2 3 4
1
Script / MC.Explorer.Goto and ftp
« on: September 21, 2022, 15:06:13 »
Hi,
I now have this little user command
Code: [Select]
MC.SetActivePanel PANEL=TOGGLE
MC.Explorer.NewBrowser
MC.Explorer.Goto PATH=ftp:\jcremers.com

And it is set to Ctrl-0 so every time i need to update something on the server i can just use the keypress.

However on each successful connect it also adds another ftp icon on the top of the window, and after a while it sometimes won't even connect anymore.
Is there a way i can keep or re-use the first successful connection with the same script / keypress?

This is driving me crazy. The toolbar gets filled with ftp icons and when you click on them i just get an error beep because they are old and disconnected.
I disabled the error window because it's so small to click on the X to close it and it doesn't help the issue.
I'd like an easy reliable way to connect a panel to the ftp server with a keystroke. I'm must be missing something.

2
Script / Re: syntax for MC.Explorer.Goto PATH=ftp:mysite.com ?
« on: August 04, 2022, 13:18:54 »
I had two different entries in the bookmarks, i removed the duplicate, now it works fine.
Thanks again. Greatest filemanager there is.

3
Script / Re: syntax for MC.Explorer.Goto PATH=ftp:mysite.com ?
« on: August 04, 2022, 11:58:20 »
Thanks Matthias.
But this is not ftp script, its just

Code: [Select]
MC.SetActivePanel PANEL=TOGGLE
MC.Explorer.NewBrowser
MC.Explorer.Goto PATH=FTP:\jcremers.com

So i don't send any path myself, mc makes those CWD itself, and they are incorrect, they should start at /home/username/domains/jcremers.com/public_html/

4
Script / syntax for MC.Explorer.Goto PATH=ftp:mysite.com ?
« on: August 03, 2022, 21:07:10 »
I've been having some trouble with ftp lately, the hoster made some changes and it's better now but it seems i have to revise some scripts because they don't work as expected anymore.

what exactly is the syntax for MC.Explorer.Goto PATH=ftp:mysite.com please? It doesn't work as expected.

Strange things happening, and after 'Server request denied' i don't see a panel, but it does NOOP so it's still connected.

2022-08-03 21:27:47 = Connection to site: jcremers.com on port 21
2022-08-03 21:27:47 < 220 ProFTPD Server ready.
2022-08-03 21:27:47 > USER [xxxxx]
2022-08-03 21:27:47 < 331 Password required for [xxxxx]
2022-08-03 21:27:47 > PASS (hidden)
2022-08-03 21:27:47 < 230 User [xxxxx] logged in
2022-08-03 21:27:47 > SYST
2022-08-03 21:27:47 < 215 UNIX Type: L8
2022-08-03 21:27:47 > FEAT
2022-08-03 21:27:47 < 211-Features:
2022-08-03 21:27:47 <  AUTH TLS
2022-08-03 21:27:47 <  CCC
2022-08-03 21:27:47 <  CLNT
2022-08-03 21:27:47 <  EPRT
2022-08-03 21:27:47 <  EPSV
2022-08-03 21:27:47 <  HOST
2022-08-03 21:27:47 <  LANG ja-JP;zh-CN;bg-BG;en-US;ru-RU;it-IT;es-ES;ko-KR;fr-FR;zh-TW
2022-08-03 21:27:47 <  MDTM
2022-08-03 21:27:47 <  MFF modify;UNIX.group;UNIX.mode;
2022-08-03 21:27:47 <  MFMT
2022-08-03 21:27:47 <  MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.groupname*;UNIX.mode*;UNIX.owner*;UNIX.ownername*;
2022-08-03 21:27:47 <  PBSZ
2022-08-03 21:27:47 <  PROT
2022-08-03 21:27:47 <  RANG STREAM
2022-08-03 21:27:47 <  REST STREAM
2022-08-03 21:27:47 <  SIZE
2022-08-03 21:27:47 <  SSCN
2022-08-03 21:27:47 <  TVFS
2022-08-03 21:27:47 <  UTF8
2022-08-03 21:27:47 < 211 End
2022-08-03 21:27:47 > CLNT MultiCommander
2022-08-03 21:27:47 < 200 OK
2022-08-03 21:27:47 > OPTS UTF8 ON
2022-08-03 21:27:47 < 200 UTF8 set to on
2022-08-03 21:27:47 > TYPE A
2022-08-03 21:27:47 < 200 Type set to A
2022-08-03 21:27:47 > MODE S
2022-08-03 21:27:47 < 200 Mode set to S
2022-08-03 21:27:47 > STRU F
2022-08-03 21:27:47 < 200 Structure set to F
2022-08-03 21:27:47 > CWD /domains/jcremers.com
2022-08-03 21:27:47 < 550 /domains/jcremers.com: No such file or directory
2022-08-03 21:27:47 = Server request denied
2022-08-03 21:27:47 > CWD /domains/jcremers.com/public_html
2022-08-03 21:27:47 < 550 /domains/jcremers.com/public_html: No such file or directory
2022-08-03 21:27:47 = Server request denied



5
Support and Feedback / Re: Ftp stopped working :(
« on: August 01, 2022, 13:32:52 »
Multicommander connects fine to another ftp server, so it seems to be something on the server side.

6
Support and Feedback / Re: Ftp stopped working :(
« on: July 29, 2022, 17:57:06 »
Total commander connects fine. :(
Still searching..

7
Support and Feedback / Re: Ftp stopped working :(
« on: July 29, 2022, 15:25:09 »
i'm looking everywhere.. :(
Windows explorer connects too.

8
Support and Feedback / Re: Ftp stopped working :(
« on: July 29, 2022, 14:55:20 »
firewall is off.

9
Support and Feedback / Ftp stopped working :(
« on: July 29, 2022, 14:20:13 »
I think this *might* be related to a windows update a few days ago.
Ftp stopped working on mc (and on the notepad++ ftp plugin), so i'm pretty [censored].
Mc gives me timed out errors. Firewall is off (i hope, i've read someone saying an update changed ftp rules).
It still works on winscp and on filezilla.
Please help :)

10
Feature Requests and Suggestions / Split / Combine files
« on: July 23, 2022, 13:17:16 »
I sometimes use this feature and have to use another filemanager for it. Would appreciate it if it's in MC.

11
Matthias it could indeed be locked tabs that generate a new one. I will keep an eye on it. Thank you.

12
Hi,
What could cause mc to generate extra c:\ tabs? Always on the right pane at the end, just now i counted 19! Or maybe it does it when i'm working with it and i just don't see it..
I have mc always running, never close it down.

13
Beta Releases / Re: Version 12 * BETA *
« on: June 17, 2022, 20:09:28 »
I tried the beta again, it works ok now, if it doesn't anymore, i'll come screaming. :)

14
Beta Releases / Re: Version 12 * BETA *
« on: June 17, 2022, 19:51:21 »
Hi Mathias,

I reverted to the non beta. Everytime mc got focus, from alt-tab and back for instance, it created a new tab on C: on the right side. After a while, i had several extra c: tabs.

15
Support and Feedback / what a great software this is
« on: August 23, 2021, 16:50:38 »
Just my appreciation, thank you.

16
Support and Feedback / Re: can't find "Open in New Tab"
« on: July 04, 2021, 18:49:17 »
Thanks Mattias, got it working, nice feature.

17
Support and Feedback / can't find "Open in New Tab"
« on: July 04, 2021, 15:01:58 »
Excuse for being dumb but i can't find it. Where is it?

18
Support and Feedback / multirename and iso / utf issues
« on: November 09, 2020, 15:55:28 »
Hello,
I downloaded a bunch of youtube movies and i'm having trouble with iso encoding in filenames.
I was hoping multirename would help but if i for instance try to rename Dvorák to Dvorak it does not rename those files.
I have lots of these files so i'm really hoping for an automated solution, i tried some tools but had little succes.

19
Beta Releases / Re: v10.0 RC 2733
« on: October 29, 2020, 07:59:26 »
Wow, it works great, thanks.

If it is unchecked so that it does not auto switch tab , pressing ctrl+shift will force it to switch tab

20
Beta Releases / Re: v10.0 RC 2733
« on: October 28, 2020, 17:38:22 »
Mathias, while it's great to be able to just drag outside Mc to another app, copying / moving something to another tab in Mc with this setting is not possible anymore. While dragging a file over a tab the cursor changes into a + indicating that it could be copied / moved but releasing the cursor does not do anything.

Could you make it dependant on whether control or alt is pressed when you start to drag? That way we could have both worlds. Ctrl-drag will not change to a tab but a normal drag will, or something like that.

Thanks.

21
Beta Releases / Re: v10.0 RC 2733
« on: October 28, 2020, 15:18:04 »
Thanks Mathias.

22
Beta Releases / Re: v10.0 RC 2733
« on: October 27, 2020, 12:37:24 »
Please how about the option to not change tabs when dragging a file out of MC? Still can't find it.
Also where is the changelog for 2735 please?

23
Support and Feedback / Re: How to color panels ?
« on: October 04, 2020, 10:35:59 »
See configuration - Explorer panel settings - Colors - Active/Inactive panel.

24
In the bar with the virtual drive buttons, Mc displays a red cross if a network share is not present, however if i right click on it to try and disconnect it, it shows 'not responding' for a while.
Can't it just disconnect such a drive and remove the icon?
I suspect this is a cause for the general unresponsiveness and long loading times that i sometimes when (re)starting Mc when it tries to load disconnected drives.

25
Beta Releases / Re: v10.0 b2725
« on: September 23, 2020, 10:08:03 »
Yes FTP is working again here.

Pages: [1] 2 3 4