Author Topic: Saving column layout bug  (Read 351 times)

Void

  • Active Member
  • ***
  • Posts: 57
    • View Profile
Saving column layout bug
« on: February 12, 2019, 13:17:55 »
Hi. First thank you for all your great work! MC is just amazing and I use it every day (humble thank donation sent yesterday)
I've been using MC for a long time and I think i had this problem before in the past too but i somehow got it liveable, yet now reinstalling on new pc i'm facing it hard again: i can't seem to save the column layout. All i want is that i have 2-3 columns with files (i'm not sure but years ago i might've even proposed this feature and it was implemented). I just can't seem to make MC remember my settings. I've tried everything I could think of:
a) right cllicking and unchecking ext, genrre, date, length fields. They dissapear, but i close and restart and they're back
b) customize columns and removing them from there, didn't work either
c) save a profile with them gone, i seemed to have partial success but only partial, I have created first the profile Void and then another one called iXaarii and they are indeed saved, which does help in restoring faster, but I still have to do it manually as the defaults seem to be lost on each closing and reopenning of MC.
d) Funnily enough one side did sort-of remember the settings so i can right click there and say "save current as default" which makes the right side also go to that state, but this sate too is imperfect and still has the EXT column when i'd like to have them without any columns at all
e) i've tried from customize settings everything i could think of, different settings, saving as new, making micro changes and then clicking update for each name & ext and then save changes... still lost on restart
f) then i noticed autoset for these paths so i tried with c:\ and with * and neither seemed to work.
g) I've tried configuration->Explorer panel settings - > autosize columns on and off as well as others there and no results

Attaching screenshots for what I mean. Would love to have these settings saved so i don't have to manually restore them on each restart of MC. Obviously i managed to get SOME progress by randomly repeating tens of times any and all of the above steps in all orders I could think of, but didn't manage to do it as I wanted, and I couldn't figure out what actually got it to save.

What I want in short is: for ALL paths, on all drives, set so as i can see 2-3 columns of files.

PS: could this be a bug somehow linked to quick paths which i use a lot? Settings even when i manage to have them changed/applied seem to reset for my most crucial folder: c:\wrk to which i'm constantly travelling to by pressing ctrl+3 via quickpath favorites (aaaamazing feature, btw). This can't be the whole of it as even without this I do lose the settings when I restart MC but I thought i should mention it in case it's part of the bug. (Named attachment screenshots with explanations)

Thank you for your patience and in advance for your help and of course again and again for all the work you put into MC all over the years and making it such a wonderful productivity tool! thank you!!!

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3306
    • View Profile
    • Multi Commander
Re: Saving column layout bug
« Reply #1 on: February 12, 2019, 14:41:20 »
You customize column two ways
From the customize column dialog.  If you want to always have other columns you need to modify the  [Default]  column profile,  Change to [Default] in customize columns. Add column. press save changes.. close and restart and you now have the new column

But you can also add column , resize column and then select "save current layout as default" from the popup menu when right clicking on the header.  Then that layout will be the default layout

"AutoSize columns" option should be on if you want the last column to use all the available space on the row. (Most of the time you want that.)

If they settings are not saved.. Makesure the config file ColumnSets.xml is rewritten when saving and make sure it is not write protected
« Last Edit: February 12, 2019, 14:47:05 by Mathias (Author) »

Void

  • Active Member
  • ***
  • Posts: 57
    • View Profile
Re: Saving column layout bug
« Reply #2 on: February 12, 2019, 15:10:31 »
as I was saying, I have done all that and it still loses all settings after restarting MC and reverts to states like in the screenshots attached.
ColumnSets.xml i have never personally touched so it shouldn't have wrong permissions. But if so, where do i find it and how should I set the permissions?

AlanJB

  • Power Member
  • ****
  • Posts: 253
  • VERY old Programmer
    • View Profile
Re: Saving column layout bug
« Reply #3 on: February 12, 2019, 17:27:08 »
ColumnSets.xml  is in the Config folder of your MC profile.

If it is not write-protected, could you post the contents of it here (no personal data is contained in it)?

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3306
    • View Profile
    • Multi Commander
Re: Saving column layout bug
« Reply #4 on: February 12, 2019, 23:12:09 »
if you save a new column setup this file will be updated..

The contain is just the configuration of the columns

AlanJB

  • Power Member
  • ****
  • Posts: 253
  • VERY old Programmer
    • View Profile
Re: Saving column layout bug
« Reply #5 on: February 13, 2019, 09:45:43 »
Hi Mathias.

Yeah, I know that:  I was just going to check that the structure of the file was sane ;)

Void

  • Active Member
  • ***
  • Posts: 57
    • View Profile
Re: Saving column layout bug
« Reply #6 on: February 13, 2019, 12:23:29 »
I have searched in where I guessesd you might mean C:\Program Files\MultiCommander (x64)\Config\ and i can't find a ColumnSets.xml
(attaching screenshot, also with version number)
That is weird because obviously the settings exist (second screenshot attached)
And as I was saying I have managed to get my iXaarii profile have what i want, I can even set it as default which seems to apply it to both side... it just doesn't remember it on restart.

AlanJB

  • Power Member
  • ****
  • Posts: 253
  • VERY old Programmer
    • View Profile
Re: Saving column layout bug
« Reply #7 on: February 13, 2019, 17:20:47 »
Apologies - I use the portable version, so my file paths are different.

Your file will be on the path:

C:\Users\[USERNAME]\AppData\Roaming\MultiCommander\Config\ColumnSets.xml.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3306
    • View Profile
    • Multi Commander
Re: Saving column layout bug
« Reply #8 on: February 14, 2019, 07:25:37 »
I have searched in where I guessesd you might mean C:\Program Files\MultiCommander (x64)\Config\ and i can't find a ColumnSets.xml
(attaching screenshot, also with version number)
That is weird because obviously the settings exist (second screenshot attached)
And as I was saying I have managed to get my iXaarii profile have what i want, I can even set it as default which seems to apply it to both side... it just doesn't remember it on restart.
Personal config is not stored in program files folder.. that folder is not writeable for program data.
As AlanJB say..  check under user profile folder
or type ":goconfig" in the commandline field inside MC. it will take you to the config folder

Void

  • Active Member
  • ***
  • Posts: 57
    • View Profile
Re: Saving column layout bug
« Reply #9 on: February 19, 2019, 17:34:39 »
okay, i used :goconfig and found the file: attaching.
I had the idea of copying everything from iXaarii to the section with default, but that just broke things, options disappeared and it changes i make also only go to the left panel. This is incredibly user unfriendly.
I would've expected that
a) any setting i have is saved at the very least on closing MC
b) if i set "use column layout iXaarii" it's applied to both
c) the right panel only gets it if i then do the extra step of "save current layout as default"
however,
d) this is all for nothing because it did not actually saves anything as default and the next time I restart MC i'm back to doing steps a, b, c all over again.

Thank you for your help! I hope these bugs will be fixed. I think i remember having similar problems years ago until i gave up with something close enough but not quite i wanted, and with settings being occasionally lost on my main computer. Now i've just bought recently two new laptops and i'm determined to at least these times finally get it figured out so hopefully i won't be back to bugging you about this one in a couple of years again... either that or i give up again :(

pS: trying to attach the xml gave some error and froze the framework so i couldn't type anymore, I guess i'll copy paste it as text:

Code: [Select]
<?xml version="1.0" encoding="UTF-8"?>
<columnsets>
  <columnset name="Pictures">
    <column id="0.name" name="Name" options="0" width="295" paddingleft="0" paddingright="0" align="0" flags="4608"/>
    <column id="0.ext" name="Ext" options="0" width="30" paddingleft="0" paddingright="0" align="0" flags="16896"/>
    <column id="0.size" name="Size" options="0" width="80" paddingleft="0" paddingright="0" align="2" flags="2048"/>
    <column id="0.date" name="Date" options="0" width="110" paddingleft="0" paddingright="0" align="2" flags="2048"/>
    <column id="00AD745A5DFD49749ED4720590318BBF.img_dimensions" name="Dimensions" options="196864" width="80" paddingleft="0" paddingright="0" align="1" flags="0"/>
    <paths>
      <path recursive="1">C:\Users\Void\Pictures\</path>
      <path recursive="1">C:\Users\Public\Pictures\</path>
    </paths>
  </columnset>
  <columnset name="Music">
    <column id="0.name" name="Name" options="0" width="295" paddingleft="0" paddingright="0" align="0" flags="4608"/>
    <column id="0.ext" name="Ext" options="0" width="30" paddingleft="0" paddingright="0" align="0" flags="16896"/>
    <column id="0.size" name="Size" options="0" width="80" paddingleft="0" paddingright="0" align="2" flags="2048"/>
    <column id="0.date" name="Date" options="0" width="110" paddingleft="0" paddingright="0" align="2" flags="2048"/>
    <column id="D8C9BF26B1B74B5D91D0FC4258061466.genre" name="Genre" options="196864" width="65" paddingleft="0" paddingright="0" align="0" flags="0"/>
    <column id="D8C9BF26B1B74B5D91D0FC4258061466.length" name="Length" options="459264" width="65" paddingleft="0" paddingright="0" align="0" flags="0"/>
    <paths>
      <path recursive="1">C:\wrk\</path>
      <path recursive="1">C:\Users\Public\Music\</path>
    </paths>
  </columnset>
  <columnset name="Void">
    <column id="0.name" name="Name" options="0" width="860" paddingleft="0" paddingright="0" align="0" flags="4608"/>
    <column id="0.ext" name="Ext" options="0" width="85" paddingleft="0" paddingright="0" align="2" flags="16896"/>
    <paths>
      <path recursive="1">c:\</path>
    </paths>
  </columnset>
  <columnset name="iXaarii">
    <column id="0.name" name="Name" options="0" width="450" paddingleft="0" paddingright="0" align="0" flags="4608"/>
    <column id="0.ext" name="Ext" options="0" width="600" paddingleft="1" paddingright="10" align="2" flags="16896"/>
    <paths>
      <path recursive="1">*\</path>
      <path recursive="1">c:\</path>
    </paths>
  </columnset>
  <columnset name="Default" default="1" extid="0">
    <column id="0.name" name="Name" options="0" width="345" paddingleft="0" paddingright="0" align="0" flags="4608"/>
    <column id="0.ext" name="Ext" options="0" width="600" paddingleft="1" paddingright="10" align="2" flags="16896"/>
  </columnset>
</columnsets>

Ulfhednar

  • Contributor
  • Elite Member
  • *****
  • Posts: 427
    • View Profile
Re: Saving column layout bug
« Reply #10 on: February 21, 2019, 14:32:59 »
Just wondering if it might be AV related?  Do you see the xml timestamp change when you update it?

I've never had this layout error, but I have had the MDV refuse to keep altered settings without my manually editing the xml.

AlanJB

  • Power Member
  • ****
  • Posts: 253
  • VERY old Programmer
    • View Profile
Re: Saving column layout bug
« Reply #11 on: February 21, 2019, 15:10:47 »
...but I have had the MDV refuse to keep altered settings without my manually editing the xml.

MDV?