Author Topic: Avoid Win Explorer Launching  (Read 115 times)

Bernd

  • Newbie
  • *
  • Posts: 4
    • View Profile
Avoid Win Explorer Launching
« on: November 26, 2019, 18:46:42 »
I have several places where the windows explorer is launched instead of showing the directory in MC. Eg. when using favorites by using the favorites menu, a right click on the file path or by using Ctrl+1. I always get the favorite directory in a windows explorer instead of MC. What is the trick?

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3459
    • View Profile
    • Multi Commander
Re: Avoid Win Explorer Launching
« Reply #1 on: November 27, 2019, 12:36:03 »
That is strange.
Right click in the Favorites windows and go to Options and enable the show path option
and make sure that the path it has in the location is a valid file path.

MC only hand off opening of a path to Windows if MC fails to open it or identify it.

Bernd

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Avoid Win Explorer Launching
« Reply #2 on: November 27, 2019, 18:36:31 »
Maybe the reason is that my favorite is a network path such as file:\\europe.mycompany.corp\winfs\mydirectory. With a local path such as C:\Program Files\Google\ it seems to work. Can I make the favorite function work with network path, because this is my 99% use case?
Also, it seems that Ctrl+v in the explorer window does not work with a network path.
Somewhat consistenty, Ctrl+p copies the local mount point of a network path instead of the network path itself. This doesn't help me when I want to send a path to collegue who most likely has a different mount point - or none at all.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3459
    • View Profile
    • Multi Commander
Re: Avoid Win Explorer Launching
« Reply #3 on: November 29, 2019, 14:06:07 »
Normal network path should work..
but file:\\ is not a normal valid file path, normal network path are \\server\share\folder
Might be that file:\\ works in WinExplorer becuse it have installed some hook for that. but it is not a standard window thing, And since MC is not build ontop in WindowsShell MC do not support specialized path like that. You should try to use real UNC path. and it should work




Bernd

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Avoid Win Explorer Launching
« Reply #4 on: November 29, 2019, 14:56:00 »
That was easy  :) Now I have working favorites and a working Ctrl+v in the explorer windows. Thank you!
I also found: when I entered a directory through a UNC path (eg. pasting it with Ctrl+v), then Ctrl+p also returns the UNC notation. But when I entered the directory through a mount point (eg. I mounted it to drive O:), then Ctrl+p returns the mount point notation. Is there a way to always get the UNC notation when I am on a network drive?
« Last Edit: November 29, 2019, 18:02:03 by Bernd »

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3459
    • View Profile
    • Multi Commander
Re: Avoid Win Explorer Launching
« Reply #5 on: December 03, 2019, 15:22:36 »
That was easy  :) Now I have working favorites and a working Ctrl+v in the explorer windows. Thank you!
I also found: when I entered a directory through a UNC path (eg. pasting it with Ctrl+v), then Ctrl+p also returns the UNC notation. But when I entered the directory through a mount point (eg. I mounted it to drive O:), then Ctrl+p returns the mount point notation. Is there a way to always get the UNC notation when I am on a network drive?

You can enable so that path for mounted network device will be UNC path when doing copy path to clipboard
Menu > Tools > To Clipboard > Resolve network path when copy mounted network path