Author Topic: FTP usb drive plugged into my router - NAS  (Read 782 times)

Oliwally

  • Contributor
  • Junior Member
  • *****
  • Posts: 29
    • View Profile
FTP usb drive plugged into my router - NAS
« on: July 16, 2021, 13:20:21 »
My WiFi router allows for the plugging in of storage via a USB port. A bit like a simple NAS I guess.

I can use a windows file explorer to access the storage via FTPin the address bar -   ftp://192.168.1.1/volume(sda1)/   and I'm in, no password needed.

However, if I try this through MC, then the Quick Connect menu ask for UN and PW. Even when I tick the anonymous option and accept the default credentials (anonymous & youremail@example.com) then I still do not get access.

For some reason it did work once through MC, but I was not able to repeat it.

How can I access my simple NAS through MC, what am I doing wrong?

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3860
    • View Profile
    • Multi Commander
Re: FTP usb drive plugged into my router - NAS
« Reply #1 on: July 16, 2021, 19:12:40 »
So you access you NAS via FTP ? I have not seen that before but that should work as long as the FTP settings are correct.
Try to change disabled "passive" mode (Toggle for PASV / PORT mode)
Also disable "Auth SSL/TLS" if the NAS do not support secure connection for FTP

Most NAS access I seen is access via network shares, But FTP should work.

Oliwally

  • Contributor
  • Junior Member
  • *****
  • Posts: 29
    • View Profile
Re: FTP usb drive plugged into my router - NAS
« Reply #2 on: July 17, 2021, 09:04:04 »
Hi Matthias, thanks for helping out!

Yes, via FTP - simply because I don't know what I'm doing and the online help I found suggested to do it this way. Not forgetting that it's not a dedicated NAS device. It's simply my TP-Link Archer VR1600v wifi router which just so happens to allow for a usb storage to be plugged into the back. Works via FTP using windows file explorer that way.

Ok, tried your suggestions and success!!   ;D  I already had the SSL/TLS disabled but now also disabled 'passive' mode and I get repeated good connections. I've attached a screenshot of the Quick Connect menu just in case others are having the same issue

Thanks very much!!

How would I use network shares....?  Ah, networking..... never have much luck with it. Just one notch beyond my understanding I think...  :-\

Regards,

Oli