Author Topic: 2.8 BETA - Bugs  (Read 8618 times)

Krekkie

  • Junior Member
  • **
  • Posts: 16
    • View Profile
2.8 BETA - Bugs
« on: December 11, 2012, 15:10:57 »
When executing the steps below I sometimes (not all the time) get this error:
Unexpected Error: WriteThread should not be running. But is is... ( ID 3001 )

Steps to follow:
- Copy a bunch of small files from a local hard disk to a network disk using F5 (I could not simulate this copying from a local hard disk to the same local hard disk).
- While it is copying, click Abort.
- Click Yes when the question to abort file copying appears.
- About 1 in 7 times the error appears.
- If the error was displayed then the question to delete an incomplete file is displayed also so I suppose it has something to do with incomplete copied files.

I don't know whether this is specific to the beta version. I installed the beta today and noticed this behavior today also but this could be a coincidence. If it helps, I could try testing in the previous version.

Using Multi Commander 2.8 BETA (build 1262) 64 bit Edition on Windows 7 Pro x64

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3602
    • View Profile
    • Multi Commander
Re: 2.8 BETA - Bugs
« Reply #1 on: December 11, 2012, 15:34:12 »
Thanks.  Will see if I can fixa that.. again.
It is not a new issue. It is a old thread timing Issue. I never been able to recreate it my self. I thought it was fixed. but apparently not.
The small file you copy.. how small are the..   2-3kb per files or 50K, 100 K ?

However. When it happens, It does not destroys anything. If the issue happens it will wait before continue when you press Ok. The issue is that it should not have to wait.

If you get the question about deleting incomplete file then the abort happen in the middle of the file. so that you now have a incomplete file. thats why it ask to delete it.

Krekkie

  • Junior Member
  • **
  • Posts: 16
    • View Profile
Re: 2.8 BETA - Bugs
« Reply #2 on: December 11, 2012, 15:54:05 »
I noticed the problem with really small files like 2-3 KB or even less than 1 KB in size but further testing shows it also happens with files smaller than 1 MB. It doesn't seem to happen with files bigger than about 1 MB. The smaller the files, the more likely it is the error appears or so it seems.

Krekkie

  • Junior Member
  • **
  • Posts: 16
    • View Profile
Re: 2.8 BETA - Bugs
« Reply #3 on: December 11, 2012, 16:19:59 »
Mathias, if you want to try some things, debug the program, log stuff or display some messages to see what's going on in a test version, I will be happy to try it out for you.
I'm a developer myself so I know how hard it is to fix something you can't reproduce yourself.

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3602
    • View Profile
    • Multi Commander
Re: 2.8 BETA - Bugs
« Reply #4 on: December 11, 2012, 18:26:15 »
If you enable file operations logging.

Core Settings > Logging > Filesystem Log
and make sure Log copy operations is active and debug level is "Debug Eval"
Then when the error happens you will have a row in the file operation log (Ctrl+L to show log view) that says
"<date> <time> Activitystatus of writethread is <num>, Should be 2."

What would be interesting to know is what digit is says in <num>


Krekkie

  • Junior Member
  • **
  • Posts: 16
    • View Profile
Re: 2.8 BETA - Bugs
« Reply #5 on: December 13, 2012, 14:47:25 »
This is an extract from the log. The information you requested is located somewhere in the middle of the text.


Code: [Select]
2012-12-13 14:32:49.288 Prepare Write - Create new file on target. : "S:\Test\test\test.xml"
2012-12-13 14:32:49.609 Operations has been requested to be paused. will wait until Pause event is signaled.
2012-12-13 14:32:49.609 CFMCopyProgressDlg::OnWorkerThreadPaused()
2012-12-13 14:32:50.686 Set Workerthread action to abort
2012-12-13 14:32:50.686 Signal workerthead to continue.
2012-12-13 14:32:50.686 PauseEvent has been signaled. Will now continue.
2012-12-13 14:32:50.686 CFMCopyProgressDlg::OnWorkerThreadContinued()
2012-12-13 14:32:50.686 Prepare Copy - Asyncrone mode enabled.
2012-12-13 14:32:50.686 Thread Copy File - Abort Request.
2012-12-13 14:32:50.686 Thread Copy File - Wait until WriteThread is paused.
2012-12-13 14:32:50.686 Thread Copy File - Leaving  (Skipped or Aborted)
2012-12-13 14:32:50.686 WriteThread should be paused here.
2012-12-13 14:32:50.686  Activitystatus of writethread is 2, should be 2
2012-12-13 14:32:50.686 [6632] WriteThread is Running. It should be paused. (3) (Thread state 2)
2012-12-13 14:32:55.133 Abort file operations request.
2012-12-13 14:32:55.133 Open target file found. and incomplete file operation found.
2012-12-13 14:32:55.134 Current file size not same as expected file size - File : "S:\Test\test\test.xml", Current Size : 0 - Expected Size : 26701
2012-12-13 14:32:55.134 Don't know if incomplete or broken files should be keep. Ask user.
2012-12-13 14:32:55.134 File Operations error : 165 File operation aborted. File might be incomplete
2012-12-13 14:32:55.134 Show Error Dialog from own thread
2012-12-13 14:32:56.436 Error Dialog Result : 0x40000 , StepFlags : 0x40001
2012-12-13 14:32:56.436 Delete incomplete or broken file.

Jungle

  • Contributor
  • Elite Member
  • *****
  • Posts: 466
  • Old Skull
    • View Profile
Re: 2.8 BETA - Bugs
« Reply #6 on: December 13, 2012, 19:45:38 »
List view navigation bug (like already mentioned). Video attached.

P.S. Why sliding effect is used in splitting panels szie (View > Split size) instead of immediate change?

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3602
    • View Profile
    • Multi Commander
Re: 2.8 BETA - Bugs
« Reply #7 on: December 15, 2012, 13:03:43 »
P.S. Why sliding effect is used in splitting panels szie (View > Split size) instead of immediate change?
It was a cool effect back in the day.. But It is a bit overplayed today. So it will be removed

Mathias (Author)

  • Administrator
  • Elite Member
  • *****
  • Posts: 3602
    • View Profile
    • Multi Commander
Re: 2.8 BETA - Bugs
« Reply #8 on: December 16, 2012, 17:04:43 »
List view navigation bug (like already mentioned). Video attached.
Should work better in the next beta (build 1267). But might still be situation where it happens, Not heavily tested
« Last Edit: December 16, 2012, 17:36:38 by Mathias (Author) »