Recent Posts

Pages: [1] 2 3 4 5 ... 10
1
OneDrive is using virtual placeholder files (might be that other cloud venders also have moved over to that), Windows has done some changes to how they are identified, and they are now colliding with how junctions links are identified.

2
Thanks for the quick reply. The Menu > Tools > Calculate folder size command returns 0 bytes.  Same if I click the KB icon in the toolbar

Upon further experimentation, I have observed the folder sizes are NOT calculated for any locally stored folders on Microsoft OneDrive and BoxDrive on my C: drive. 

Other cloud folders like DropBox and GoogleDrive folders calculate the file sizes perfectly.  But OneDrive and BoxDrive will not calc the sizes and always return 0 bytes after I recalculate the folder sizes. I recently installed OneDrive on my new laptop and noticed it. This issue has never happened before. It's very strange indeed!

I don't understand what's different about the OneDrive and  BoxDrive folder permissions.  I checked and have full control on the security tab of the folder properties dialog.  I'm also running under my Windows 11 64-bit administrator account.

Any thoughts or suggestions to try next?  It's driving me crazy!  Thanks in advance
3
Im not able to reproduce that
If you start foldersize from shortcut or from Menu > Tools > Calculate folder size , Same result ?

Is there something special with those folder ? permission ? symlinks or something ?

The "Always rescan folders" has nothing to do with folder sizing. It is if a folder always should should rescan the content of the folder when entering, even if folder hint say nothing has changed
4
Hi Mathias

I don't see a problem for you as author adding the information to Wikipedia.  Consider that you (the developer) would be the only one to possess the technical details in the first place. You worked long and hard on MC, why not promote it and attract more users seeking the best file manager out there?

If you like, I am willing to edit the Wikipedia on your behalf, but I need your help to gather the MC technical information for the Wikipedia knowledge article. I think this would be great info to provide others looking to discover the awesome power and utility of MultiCommander!

I've created an Excel spreadsheet containing technical details (as much as I could gather) for you to review for accuracy.  See attached zip file. There are 8 tabs, one for each Wikipedia section in the article. I've collected everything in one place to make it easier for you to review and edit.

I know you're busy, but if/when you have the time, kindly please review/edit the Excel workbook and email me privately and I am more than willing to post MultiCommander information on Wikipedia here: https://en.wikipedia.org/wiki/Comparison_of_file_managers

Cheers and thank you!  I eagerly await your response.
AB


ps sorry for the many edits but I lost my original post while editing in this forum, so I have consolidated my replies to reduce noise.
5
Calculate Folder Size is broken.  The size of folders is not refreshed. When I click on the KB toolbar icon (or press Shift+Alt+Return), the DIR size shows 0 bytes.  See before and after images below.

Note: The "Always rescan folders" setting under Explorer panel settings has no effect.  I used to keep this enabled, but that doesn't solve my issue which I only noticed recently.
6
Thank you for making multitasking easier —I really needed this feature desperately ! This will take my productivity to new heights ! Thank you so much, appreciate it ! 👍
7
It runs a separate blank session (from a 64bit process) than when I run it from Taskbar or Explorer or some 32bit process. I guess the Registry for that must be virtualized or something. According to Gemini AI you'd need to use Process Injection to load a DLL into Multicommander & then run it as 32bit ! 😅 But it's O.K. it runs all my tabs fine from the Taskbar icon.
Quote
Process Injection (Advanced and Risky):
Theory: This involves injecting a 32-bit DLL into the 64-bit File Manager process, then using that DLL to launch QREAD in the desired environment.
It's alright though, there's no way around it. I even tried loading WinFile (Github the original File Manager from Win 3.11) & also /w Total Commander 32bit through Multicommander, but it doesn't load it correctly. There were some advanced COMSPEC .BAT files or something I read about long time back but those didn't work either. It's fine ! 👍 I also tried getting the 32bit version by running it through Otya128's WineVDM (Github) but it gives an error (I think it only emulates 16-bit apps.)
8
Not sure what issue you have, I have not seen any issue running 32bit apps. Run lots of them.
Yes Windows will virtualize some system folders for them. But that is needed else it would not run. part of the emulation. Eg System dlls must be loaded from Windows\SySWOW64  and not System32\ folder,  (That it is called 32 is just for combability reason. for 64bit version it contain 64bit version of dlls)
9
Oh I see. No it is not .NET app, it's a very old 90's Text Editor app that runs on 32bit by default.
10
MC do not have any control over that.. that is handled by Windows.

WOW64 is what allows 32bit apps to run on 64bit system.
Or is it a .NET application that are build as ANYCPU ? so it runs as 64bit on 64bit system and 32bit on 32bit system ?
If it is .NET application you can force it to run in 32bit with

CorFlags.exe App.exe /32Bit+

and with you can then remove that flag again with
CorFlags.exe App.exe /32Bit-

Pages: [1] 2 3 4 5 ... 10