Author Topic: User defined command shortcuts not working after updating to 11.0  (Read 1215 times)

Alucard2k

  • Newbie
  • *
  • Posts: 14
    • View Profile
Hello,

Today, when I started Multicommander, it prompted me to update to version 11.0 Build 2770. I have a portable install on D:\multicommander

I have some User Defined commands, to run external programs. I've defined custom hotkeys to run these commands.

However, when I press the hotkeys I've defined previously, it no longer opens my custom commands.


I've added the commands to the toolbar, and clicking on the icons still works. However, this slows down my work flow, as it is faster to press the shortcuts instead of moving the mouse.

Also, for some reason, the User Commands list the icons for my programs as the compressed file icon:


Thanks.

Update: I just found out what happened. After the updater completed downloading and updating to version 11, I clicked on the "Start Multi Commander" button. This opened the program, but the hotkeys didn't work. When I closed the program and reopened from my regular shortcut, all the hotkeys work again.
« Last Edit: February 24, 2021, 05:53:10 by Alucard2k »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3886
    • View Profile
    • Multi Commander
Re: User defined command shortcuts not working after updating to 11.0
« Reply #1 on: February 24, 2021, 08:02:17 »
At first start up it converts and migrate the script to its new format. so probably somethings with hooking up key binding after migration. I will look at that.

The Zip icon is because the each script is now stored as separate files. And script files can be bundle together in a zip.. and all scripts migrated from previous version are bundled into a zip in the script folder. And if they are located inside a zip, you see the zip icon.

Alucard2k

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: User defined command shortcuts not working after updating to 11.0
« Reply #2 on: February 24, 2021, 22:16:23 »
Thank you for your reply.

I've been using my shortcuts for a while now, and I was worried they would no longer work.