Author Topic: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue  (Read 1063 times)

Lukasz S.

  • Junior Member
  • **
  • Posts: 17
    • View Profile
Hi,

There is some issue during starting MC, when initializing Explorer Panel, MC freezes and there is no chance to start it at all.
Restart doesn't help.

 Here is few file logs.

There is something wrong with ExplorerPanel.xml file I attach it. After deleting it MC starts.

I found that mentioned xml file had last rows like this:
</config>
<DelayUpdate value="1"/>
<onlylocal value="0"/>
<onlylocked value="0"/>
<itemfocus value="1"/>
<sort value="1"/>


but should be (after copy + paste MC starts):
  <startup>
    <DelayUpdate value="0"/>
    <onlylocal value="0"/>
    <onlylocked value="0"/>
    <itemfocus value="1"/>
    <sort value="1"/>
  </startup>
</config>

After last update I started only one time MC, I'm curious why xml file has changed after second start.

BR
Lukasz
« Last Edit: March 29, 2021, 21:58:11 by Lukasz S. »
Polish translator
Lukasz S.

Ulfhednar

  • Contributor
  • VIP Member
  • *****
  • Posts: 462
    • View Profile
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #1 on: March 29, 2021, 22:58:24 »
Updated & ran this build OK for 5hrs approx.
Subsequently shut down & restarted PC & now hangs on splash screen at ''Loading extension : Explorer Panel'' statement.
Needs to be terminated via Task Manager.  Running as Admin on win10 x64.

Following Lukasz' comment, I altered the end section of the ExplorerPanel.xml file & MC then correctly starts.
I.E.
Code: [Select]
<DelayUpdate value="1"/>
<onlylocal value="0"/>
<onlylocked value="0"/>
<itemfocus value="1"/>
<sort value="1"/>

<<<< I commented out this trailing extra block>>>>

<!--<DelayUpdate value="1"/>-->
<!--<onlylocal value="0"/>-->
<!--<onlylocked value="0"/>-->
<!--<itemfocus value="1"/>-->
<!--<sort value="1"/>-->

Closing MC reverts to lock-up at next start with ExplorerPanel.xml being incorrectly formatted again.

Need your help Mathias ;)
« Last Edit: March 29, 2021, 23:05:22 by Ulfhednar »

skrzat

  • Junior Member
  • **
  • Posts: 15
    • View Profile
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #2 on: March 30, 2021, 08:23:08 »
I have the same problem :(

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3815
    • View Profile
    • Multi Commander
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #3 on: March 30, 2021, 12:36:01 »
Hmm strange I have not been able to recreate the issue yet,
the settings "DelayUpdate" is new. But not sure how the xml file can get corrupted. and why it hangs.. even if fails to read config it should continue..
When reading the xml and a settings is missing it will be added, 

MC Freezes. Is it possible for you or anyone else that have this issue to go into task manager and right click on MC there and select Create Dump File. and then zip/7z that dump file and upload it to
http://multicommander.com/upload/


Hi,

There is some issue during starting MC, when initializing Explorer Panel, MC freezes and there is no chance to start it at all.
Restart doesn't help.

 Here is few file logs.

There is something wrong with ExplorerPanel.xml file I attach it. After deleting it MC starts.

I found that mentioned xml file had last rows like this:
</config>
<DelayUpdate value="1"/>
<onlylocal value="0"/>
<onlylocked value="0"/>
<itemfocus value="1"/>
<sort value="1"/>


but should be (after copy + paste MC starts):
  <startup>
    <DelayUpdate value="0"/>
    <onlylocal value="0"/>
    <onlylocked value="0"/>
    <itemfocus value="1"/>
    <sort value="1"/>
  </startup>
</config>

After last update I started only one time MC, I'm curious why xml file has changed after second start.

BR
Lukasz

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3815
    • View Profile
    • Multi Commander
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #4 on: March 30, 2021, 13:05:15 »
Workaround for failure to read config file.

User settings file in C:\Users\[USERNAME]\AppData\Roaming\MultiCommander\Config\ or Config/ in portable
Edit ExplorerPanel.xml

make sure there is nothing after the </config> in at the bottom.
And after the </save> add a "<startup></startup>" tag  the problem might be that it creates this tag in the wrong place. it ends up in the root of the xml tree if it is missing.

Code: [Select]
  <save>
    <path value="1"/>
    <onlylocal value="1"/>
    <sort value="1"/>
  </save>
  <startup>
  </startup>

skrzat

  • Junior Member
  • **
  • Posts: 15
    • View Profile
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #5 on: March 30, 2021, 13:39:43 »
It works. It seems like section <startup></startup> was missing and config lines were added at the end of file (after </config>).

Ulfhednar

  • Contributor
  • VIP Member
  • *****
  • Posts: 462
    • View Profile
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #6 on: March 31, 2021, 14:40:34 »
Hi Mathias.
I can see the values that are added at the end of the xml in what I assume is the correct place:-
Code: [Select]
  </tweak>
    <SortLanguageAware value="0"/>
    <SortFilesBeforeFolders value="0"/>
    <AdjustDateTimeForDTS value="1"/>
    <HighlightSortColumn value="0"/>
  </layout>
  <tweak>
    <CacheRowData value="0"/>
  </tweak>
  <save>
    <path value="1"/>
    <onlylocal value="1"/>
    <sort value="1"/>
    <onlylocked value="0"/>
    <itemfocus value="1"/>
  </save>       
  <selection>
    <comparefolders>
      <files value="1"/>
      <folders value="1"/>
    </comparefolders>

these are echoed at the end on MC shut down as I said.
I added the
 <startup>
  </startup>
beneath   </save>
& MC removed the starup entries & echoed those lines again & is back hanging on the 'loading' comment.

Tried uploading a dmp  & 
Quote
Sorry, there was a problem uploading your file.

Storage is low on free disk space

......I'll try again later  ;)

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3815
    • View Profile
    • Multi Commander
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #7 on: March 31, 2021, 15:43:37 »
Hi Mathias.
I can see the values that are added at the end of the xml in what I assume is the correct place:-
Code: [Select]
  </tweak>
    <SortLanguageAware value="0"/>
    <SortFilesBeforeFolders value="0"/>
    <AdjustDateTimeForDTS value="1"/>
    <HighlightSortColumn value="0"/>
  </layout>
  <tweak>
    <CacheRowData value="0"/>
  </tweak>
  <save>
    <path value="1"/>
    <onlylocal value="1"/>
    <sort value="1"/>
    <onlylocked value="0"/>
    <itemfocus value="1"/>
  </save>       
  <selection>
    <comparefolders>
      <files value="1"/>
      <folders value="1"/>
    </comparefolders>

these are echoed at the end on MC shut down as I said.
I added the
 <startup>
  </startup>
beneath   </save>
& MC removed the starup entries & echoed those lines again & is back hanging on the 'loading' comment.

Tried uploading a dmp  & 
Quote
Sorry, there was a problem uploading your file.

Storage is low on free disk space

......I'll try again later  ;)

So you do not have any items outside of the </config> tag ? and you have a startup tag inside the config tag ?
Sure that you do not have a dialog with a error msg behide the splash screen.. alt tab to find it ?

Ulfhednar

  • Contributor
  • VIP Member
  • *****
  • Posts: 462
    • View Profile
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #8 on: March 31, 2021, 17:12:44 »
Hi Mathias.
I deleted all lines below <\config> & added the <startup> tags below </save>as you showed in your post.
So that section I used as example is :-
Code: [Select]
  </tweak>
    <SortLanguageAware value="0"/>
    <SortFilesBeforeFolders value="0"/>
    <AdjustDateTimeForDTS value="1"/>
    <HighlightSortColumn value="0"/>
  </layout>
  <tweak>
    <CacheRowData value="0"/>
  </tweak>
  <save>
    <path value="1"/>
    <onlylocal value="1"/>
    <sort value="1"/>
    <onlylocked value="0"/>
    <itemfocus value="1"/>
  </save>   
 <startup>
  </startup>   
  <selection>
    <comparefolders>
      <files value="1"/>
      <folders value="1"/>
    </comparefolders>

Closing & restarting MC appends the lines from the <save> section =
Code: [Select]
</config>
<DelayUpdate value="1"/>
<onlylocal value="0"/>
<onlylocked value="0"/>
<itemfocus value="1"/>
<sort value="1"/>
& MC hangs.  <startup> is removed from the xml.
MC isn't even listed in the alt+tab window.  The splash screen appears on the desktop & that's it.
MC must be accessed & killed via TM.


I ran windbg on the dump to see if that would help.
Here's the output:

Code: [Select]
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

*** WARNING: Unable to verify checksum for MultiCommander.exe

KEY_VALUES_STRING: 1

    Key  : Analysis.CPU.Sec
    Value: 1

    Key  : Analysis.DebugAnalysisProvider.CPP
    Value: Create: 8007007e on DESKTOP-LDE1BEV

    Key  : Analysis.DebugData
    Value: CreateObject

    Key  : Analysis.DebugModel
    Value: CreateObject

    Key  : Analysis.Elapsed.Sec
    Value: 28

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 71

    Key  : Analysis.System
    Value: CreateObject

    Key  : Timeline.OS.Boot.DeltaSec
    Value: 5827

    Key  : Timeline.Process.Start.DeltaSec
    Value: 178


NTGLOBALFLAG:  0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

APPLICATION_VERIFIER_FLAGS:  0

EXCEPTION_RECORD:  (.exr -1)
ExceptionAddress: 0000000000000000
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 0

FAULTING_THREAD:  00003ebc

PROCESS_NAME:  MultiCommander.exe

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_CODE_STR:  80000003

STACK_TEXT: 
000000ae`1e76adb8 00007fff`c951d6f1 : 00000000`00000000 00000000`000000e5 00000000`0003088c 00007fff`c94f0000 : win32u!NtUserWaitMessage+0x14
000000ae`1e76adc0 00007fff`c951d461 : 00000000`00000100 00000000`00000000 00000000`00000001 00000000`00000000 : user32!DialogBox2+0x261
000000ae`1e76ae60 00007fff`c956bc1b : 00000000`00010009 000000ae`1e76afc0 000000ae`1e76b1e0 00000288`571b1120 : user32!InternalDialogBox+0x12d
000000ae`1e76aec0 00007fff`c956a535 : 00000000`00000000 00000000`000000a9 00000000`000002f0 00000000`00000032 : user32!SoftModalMessageBox+0x85b
000000ae`1e76b010 00007fff`c956b327 : 00007fff`c94feb96 00000000`00000012 00000000`0000000e 00000000`00000800 : user32!MessageBoxWorker+0x341
000000ae`1e76b1c0 00007fff`c956b3ae : 00000000`00000000 00000000`00000376 00000000`00000000 00000288`571d9f68 : user32!MessageBoxTimeoutW+0x1a7
000000ae`1e76b2c0 00007ff7`dba64a93 : 00000000`00000000 00007ff7`dc170310 00007ff7`0000007d 00000000`00000030 : user32!MessageBoxW+0x4e
000000ae`1e76b300 00007ff7`dba647c2 : 00000288`571d8e00 00007ff7`db9e5724 00000288`571dbbf0 00000288`55bf4200 : MultiCommander+0x84a93
000000ae`1e76b590 00007ff7`dbde6e06 : 00000288`571d9f68 00000000`00000000 00000288`571dbbf0 00000000`00000001 : MultiCommander+0x847c2
000000ae`1e76b5d0 00007ff7`dbde2077 : 00000288`571d8e00 00000288`571d9f68 00000288`55bf4298 00000288`55bf4201 : MultiCommander+0x406e06
000000ae`1e76b610 00007ff7`dbde277b : 000000ae`1e76b718 000000ae`1e76b701 00000288`55bf4298 00000288`55bf4298 : MultiCommander+0x402077
000000ae`1e76b660 00007ff7`dbde9fe6 : 00000000`00000000 000000ae`1e76b740 00000288`571d6f00 00000000`00002710 : MultiCommander+0x40277b
000000ae`1e76b6d0 00007ff7`dbf87374 : 00000288`571d6f00 00007ff7`db9e6501 000000ae`1e76b870 ffffc148`3d83c610 : MultiCommander+0x409fe6
000000ae`1e76b760 00007ff7`dbf1dce3 : 00000288`571d6fc0 000000ae`1e76b800 000000ae`1e76b870 00000288`572807a0 : MultiCommander+0x5a7374
000000ae`1e76b7a0 00007ff7`dbf2ebb5 : 00000288`00000000 00000288`5719e510 00000288`571d6fb0 00000288`571d6fa0 : MultiCommander+0x53dce3
000000ae`1e76b810 00007ff7`dbf304c7 : 00000288`55bf4400 00000288`5719e510 00000288`571d6fb0 00000288`571d6fc8 : MultiCommander+0x54ebb5
000000ae`1e76b870 00007ff7`dbdf5de1 : 00000288`57168c90 00000288`571d6ff8 00000288`571dbd90 00000000`00000052 : MultiCommander+0x5504c7
000000ae`1e76f9c0 00007ff7`dbdfa864 : 00000288`55bf4380 000000ae`1e76fab0 00000288`571d6fa0 00000288`56fc6af0 : MultiCommander+0x415de1
000000ae`1e76fa00 00007ff7`dbc1f5ff : 00000288`571d63b8 000000ae`1e76fab0 00000288`56fc6af0 00007ff7`dc028a01 : MultiCommander+0x41a864
000000ae`1e76fa40 00007ff7`dbc23a35 : 00000288`570b9c48 00000000`00000001 00000000`00000000 00000288`55bf4290 : MultiCommander+0x23f5ff
000000ae`1e76fad0 00007ff7`dbccea49 : 00000288`55c29af0 00000288`55c655b0 00007ff7`dc170310 00000288`55bf0850 : MultiCommander+0x243a35
000000ae`1e76fb70 00007ff7`dbcda419 : 00000000`03e30123 00007ff7`dba6111c 00007ff7`dc170310 00000288`55cc85c8 : MultiCommander+0x2eea49
000000ae`1e76fba0 00007ff7`dbb30fe3 : 00000288`00000000 00000000`00000001 00000000`00000000 00000288`53b324e0 : MultiCommander+0x2fa419
000000ae`1e76fc90 00007ff7`dbaa6f6e : 00000000`00000001 00000000`00000000 00000000`00000000 00000000`00000000 : MultiCommander+0x150fe3
000000ae`1e76fcd0 00007fff`c8107034 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : MultiCommander+0xc6f6e
000000ae`1e76fd10 00007fff`c9efd0d1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
000000ae`1e76fd40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21


STACK_COMMAND:  ~0s; .ecxr ; kb

SYMBOL_NAME:  win32u!NtUserWaitMessage+14

MODULE_NAME: win32u

IMAGE_NAME:  win32u.dll

FAILURE_BUCKET_ID:  BREAKPOINT_80000003_win32u.dll!NtUserWaitMessage

OS_VERSION:  10.0.19041.1

BUILDLAB_STR:  vb_release

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

FAILURE_ID_HASH:  {a106cd41-a8b1-c51d-6d94-a75661270841}

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3815
    • View Profile
    • Multi Commander
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #9 on: March 31, 2021, 22:28:27 »
You must be doing something wrong.  What messes things up is that it does not find  <startup> when starting, If it is there it will not try to create it and then create it in the wrong place
Was MC running when you edit the file ? make sure MC is not running when you save the config, It may save it when you close MC

The hang is because a messagebox is shown and waiting to be clicked.

(a new version with it fixed come tomorrow when I get home.)

/Mathias

Hi Mathias.
I deleted all lines below <\config> & added the <startup> tags below </save>as you showed in your post.
So that section I used as example is :-
Code: [Select]
  </tweak>
    <SortLanguageAware value="0"/>
    <SortFilesBeforeFolders value="0"/>
    <AdjustDateTimeForDTS value="1"/>
    <HighlightSortColumn value="0"/>
  </layout>
  <tweak>
    <CacheRowData value="0"/>
  </tweak>
  <save>
    <path value="1"/>
    <onlylocal value="1"/>
    <sort value="1"/>
    <onlylocked value="0"/>
    <itemfocus value="1"/>
  </save>   
 <startup>
  </startup>   
  <selection>
    <comparefolders>
      <files value="1"/>
      <folders value="1"/>
    </comparefolders>

Closing & restarting MC appends the lines from the <save> section =
Code: [Select]
</config>
<DelayUpdate value="1"/>
<onlylocal value="0"/>
<onlylocked value="0"/>
<itemfocus value="1"/>
<sort value="1"/>
& MC hangs.  <startup> is removed from the xml.
MC isn't even listed in the alt+tab window.  The splash screen appears on the desktop & that's it.
MC must be accessed & killed via TM.


I ran windbg on the dump to see if that would help.
Here's the output:

Code: [Select]
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

*** WARNING: Unable to verify checksum for MultiCommander.exe

KEY_VALUES_STRING: 1

    Key  : Analysis.CPU.Sec
    Value: 1

    Key  : Analysis.DebugAnalysisProvider.CPP
    Value: Create: 8007007e on DESKTOP-LDE1BEV

    Key  : Analysis.DebugData
    Value: CreateObject

    Key  : Analysis.DebugModel
    Value: CreateObject

    Key  : Analysis.Elapsed.Sec
    Value: 28

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 71

    Key  : Analysis.System
    Value: CreateObject

    Key  : Timeline.OS.Boot.DeltaSec
    Value: 5827

    Key  : Timeline.Process.Start.DeltaSec
    Value: 178


NTGLOBALFLAG:  0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

APPLICATION_VERIFIER_FLAGS:  0

EXCEPTION_RECORD:  (.exr -1)
ExceptionAddress: 0000000000000000
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 0

FAULTING_THREAD:  00003ebc

PROCESS_NAME:  MultiCommander.exe

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_CODE_STR:  80000003

STACK_TEXT: 
000000ae`1e76adb8 00007fff`c951d6f1 : 00000000`00000000 00000000`000000e5 00000000`0003088c 00007fff`c94f0000 : win32u!NtUserWaitMessage+0x14
000000ae`1e76adc0 00007fff`c951d461 : 00000000`00000100 00000000`00000000 00000000`00000001 00000000`00000000 : user32!DialogBox2+0x261
000000ae`1e76ae60 00007fff`c956bc1b : 00000000`00010009 000000ae`1e76afc0 000000ae`1e76b1e0 00000288`571b1120 : user32!InternalDialogBox+0x12d
000000ae`1e76aec0 00007fff`c956a535 : 00000000`00000000 00000000`000000a9 00000000`000002f0 00000000`00000032 : user32!SoftModalMessageBox+0x85b
000000ae`1e76b010 00007fff`c956b327 : 00007fff`c94feb96 00000000`00000012 00000000`0000000e 00000000`00000800 : user32!MessageBoxWorker+0x341
000000ae`1e76b1c0 00007fff`c956b3ae : 00000000`00000000 00000000`00000376 00000000`00000000 00000288`571d9f68 : user32!MessageBoxTimeoutW+0x1a7
000000ae`1e76b2c0 00007ff7`dba64a93 : 00000000`00000000 00007ff7`dc170310 00007ff7`0000007d 00000000`00000030 : user32!MessageBoxW+0x4e
000000ae`1e76b300 00007ff7`dba647c2 : 00000288`571d8e00 00007ff7`db9e5724 00000288`571dbbf0 00000288`55bf4200 : MultiCommander+0x84a93
000000ae`1e76b590 00007ff7`dbde6e06 : 00000288`571d9f68 00000000`00000000 00000288`571dbbf0 00000000`00000001 : MultiCommander+0x847c2
000000ae`1e76b5d0 00007ff7`dbde2077 : 00000288`571d8e00 00000288`571d9f68 00000288`55bf4298 00000288`55bf4201 : MultiCommander+0x406e06
000000ae`1e76b610 00007ff7`dbde277b : 000000ae`1e76b718 000000ae`1e76b701 00000288`55bf4298 00000288`55bf4298 : MultiCommander+0x402077
000000ae`1e76b660 00007ff7`dbde9fe6 : 00000000`00000000 000000ae`1e76b740 00000288`571d6f00 00000000`00002710 : MultiCommander+0x40277b
000000ae`1e76b6d0 00007ff7`dbf87374 : 00000288`571d6f00 00007ff7`db9e6501 000000ae`1e76b870 ffffc148`3d83c610 : MultiCommander+0x409fe6
000000ae`1e76b760 00007ff7`dbf1dce3 : 00000288`571d6fc0 000000ae`1e76b800 000000ae`1e76b870 00000288`572807a0 : MultiCommander+0x5a7374
000000ae`1e76b7a0 00007ff7`dbf2ebb5 : 00000288`00000000 00000288`5719e510 00000288`571d6fb0 00000288`571d6fa0 : MultiCommander+0x53dce3
000000ae`1e76b810 00007ff7`dbf304c7 : 00000288`55bf4400 00000288`5719e510 00000288`571d6fb0 00000288`571d6fc8 : MultiCommander+0x54ebb5
000000ae`1e76b870 00007ff7`dbdf5de1 : 00000288`57168c90 00000288`571d6ff8 00000288`571dbd90 00000000`00000052 : MultiCommander+0x5504c7
000000ae`1e76f9c0 00007ff7`dbdfa864 : 00000288`55bf4380 000000ae`1e76fab0 00000288`571d6fa0 00000288`56fc6af0 : MultiCommander+0x415de1
000000ae`1e76fa00 00007ff7`dbc1f5ff : 00000288`571d63b8 000000ae`1e76fab0 00000288`56fc6af0 00007ff7`dc028a01 : MultiCommander+0x41a864
000000ae`1e76fa40 00007ff7`dbc23a35 : 00000288`570b9c48 00000000`00000001 00000000`00000000 00000288`55bf4290 : MultiCommander+0x23f5ff
000000ae`1e76fad0 00007ff7`dbccea49 : 00000288`55c29af0 00000288`55c655b0 00007ff7`dc170310 00000288`55bf0850 : MultiCommander+0x243a35
000000ae`1e76fb70 00007ff7`dbcda419 : 00000000`03e30123 00007ff7`dba6111c 00007ff7`dc170310 00000288`55cc85c8 : MultiCommander+0x2eea49
000000ae`1e76fba0 00007ff7`dbb30fe3 : 00000288`00000000 00000000`00000001 00000000`00000000 00000288`53b324e0 : MultiCommander+0x2fa419
000000ae`1e76fc90 00007ff7`dbaa6f6e : 00000000`00000001 00000000`00000000 00000000`00000000 00000000`00000000 : MultiCommander+0x150fe3
000000ae`1e76fcd0 00007fff`c8107034 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : MultiCommander+0xc6f6e
000000ae`1e76fd10 00007fff`c9efd0d1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
000000ae`1e76fd40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21


STACK_COMMAND:  ~0s; .ecxr ; kb

SYMBOL_NAME:  win32u!NtUserWaitMessage+14

MODULE_NAME: win32u

IMAGE_NAME:  win32u.dll

FAILURE_BUCKET_ID:  BREAKPOINT_80000003_win32u.dll!NtUserWaitMessage

OS_VERSION:  10.0.19041.1

BUILDLAB_STR:  vb_release

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

FAILURE_ID_HASH:  {a106cd41-a8b1-c51d-6d94-a75661270841}

Ulfhednar

  • Contributor
  • VIP Member
  • *****
  • Posts: 462
    • View Profile
Re: Re: v11.1 ** BETA ** (Updated 28-Mar) Hang At Startup Issue
« Reply #10 on: March 31, 2021, 22:57:50 »
Thanks Mathias.
I never get a msg box, so nothing I can click. Just the splash flag which is static.

But I must have had an instance active when I edited the xml.  Made sure MC was all closed & it saved it correctly this time ::) :-[
No idea why I allowed that as it is obvious.  Too long in lock-down maybe!   :D