Author Topic: Program hangs at "Reading MultiCommander Configuration"  (Read 131 times)

pyroguy7

  • Newbie
  • *
  • Posts: 3
    • View Profile
While trying to run MultiCommander (v11.0, build 2770) the popup window reports "Reading MultiCommander Configuration", but then never moves past this and hangs indefinitely.

Anyone else experience this?  I've also uploaded a .DMP file in hopes that someone can take a look and see why it's hanging.

shadonoz

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #1 on: May 05, 2021, 00:33:51 »
I am having the same problem, except MC does start after about 20 seconds.

The log shows:  2021-05-04 15:21:46.581 Dropbox appdata folder not found : "C:\Users\Dean\AppData\Roaming\Dropbox"
                        2021-05-04 15:21:46.581 GoogleDrive folder not found : "<empty>"

I do NOT use Google drive nor Dropbox.  How can I remove these from the configuration file?

Thanks.

shadonoz

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #2 on: May 05, 2021, 00:45:59 »
UPDATE:  I deleted TabSessions.xml from C:\Users\Dean\AppData\Roaming\MultiCommander\Config\

And so far, that has solved the problem.  And that file has NOT been recreated.

shadonoz

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #3 on: May 05, 2021, 01:48:15 »
NEW UPDATE:  The fix only lasted one restart.  Now it's taking over a minute looking for those same folders mentioned above.
How can I get MC to stop looking for those non-existent folders?
Thanks!
Win 10 Home 20H2 build 19042.928

BTW, my boot drive is an SSD.  Previously, MC would start within just a couple of seconds.

shadonoz

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #4 on: May 05, 2021, 08:03:37 »
SOLUTION: It was a mapped network drive.  Whenever that system was offline, MC would hang looking for the drive. I have to disconnect from that drive.  When I am disconnected, MC starts normally.
Sounds like a Windows bug, since it didn't used to behave that way.

pyroguy7

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #5 on: May 05, 2021, 16:17:42 »
That's disturbing, since I always am working with mapped drives and it has been working fine until my last reboot.  Were you able to reconnect to those mappped drives afterwards?  I usually found in the past I'd have to restart multicommander if Windows wasn't connected to the map drives yet.

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3778
    • View Profile
    • Multi Commander
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #6 on: May 05, 2021, 22:25:59 »
While trying to run MultiCommander (v11.0, build 2770) the popup window reports "Reading MultiCommander Configuration", but then never moves past this and hangs indefinitely.

Anyone else experience this?  I've also uploaded a .DMP file in hopes that someone can take a look and see why it's hanging.
I checked the dumpfile. it is "hanged" because a messagebox is shown because of some error. I can't se why. Why you don't see the messagebox directly might be that is some way gets shown behind the splash screen

pyroguy7

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #7 on: Yesterday at 00:37:51 »
Alt-tabbing and trying other various thing is revealing no messagebox showing up.  Usually there would be a sound associated with those boxes when they pop up, yeah?  Because I'm not getting that sound either.  If it's really popping up behind the splash screen, I've no way to access it.  Is there an alternative solution or workaround here? or another way to find out what the error could be?

I should say that I also tried downloading the portable version and tried to run that as well, but is unfortunately doing the same thing.

Is there any other information that would be helpful?  Windows OS build numbers? Any particular settings?

« Last Edit: Yesterday at 00:41:28 by pyroguy7 »

Mathias (Author)

  • Administrator
  • VIP Member
  • *****
  • Posts: 3778
    • View Profile
    • Multi Commander
Re: Program hangs at "Reading MultiCommander Configuration"
« Reply #8 on: Yesterday at 12:57:32 »
Alt-tabbing and trying other various thing is revealing no messagebox showing up.  Usually there would be a sound associated with those boxes when they pop up, yeah?  Because I'm not getting that sound either.  If it's really popping up behind the splash screen, I've no way to access it.  Is there an alternative solution or workaround here? or another way to find out what the error could be?

I should say that I also tried downloading the portable version and tried to run that as well, but is unfortunately doing the same thing.

Is there any other information that would be helpful?  Windows OS build numbers? Any particular settings?

Probably a configuration file is corrupt.
try rename (to .bak)
C:\Users\[**USERNAME**]\AppData\Roaming\MultiCommander\Config\ExplorerPanel.xml   ( or MultiCommander.xml )  And it wil revert that file into a default one,  rename it to .bak instead of delete then you can restore it if it was not that file

« Last Edit: Yesterday at 13:02:23 by Mathias (Author) »