Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mathias (Author)

Pages: 1 [2] 3 4 5 6 ... 161
26
Not sure. You have a locked that that allows for new tabs when browsing to subfolder ?

In what situation are new tabs coming ?  Are they poping up when the tabs is refreshed. when you navigate to somethings ?

27
Beta Releases / Re: Version 12 * BETA *
« on: July 12, 2022, 07:43:23 »
Multi Rename by using the Date mdified use  maybe the GMT..This mean it use the absolute Date and sould use the relative date for my time zone..
Not GMT but UTC,  All file times are UTC from the Filesystem.  So some UTC to Local conversion that are missing. I will look into that..

28
Beta Releases / Re: Version 12 * BETA *
« on: July 12, 2022, 07:41:52 »
Hi, there is some issue with refresh of folders view on MC start in newest beta 2888.

When I start MC there are no folder icons, see picture 1. After for example refresh or go in and out to any folder, folder icons are refreshed picture 2.

There is still some bug with showing correct keyboard shortcut for rename F2 and make folder F7 command - picture 3. Anyway shortcuts are working OK, only visualisation is wrong.

Yes the icon things is a race condtion that can happen if things are fast and there are multiple icons requests at the same time.. I got it on my list of bugs for this release

Button Panel. Yes it is a refresh issue I think. If you have modifiers for button panel active so they change when pressing ctrl / alt then they are after that redrawn correct. 

29
Nice.. Good that it works now... Then the fix for it worked.

30
Yes, makes sense.

About the "Time elapsed" thing, though? It's not an important information, but if it is so much off the real numbers then it kind of hurts more than it helps.
Not sure, Have not notice any issue with that

31
Support and Feedback / Re: Version 12 * BETA *
« on: July 07, 2022, 22:28:53 »
I deleted the registry key and had MC create a new one. Did not help. What I see is that the focus=1 values moves correctly between panel 0 and 1 depending on how I close MC. But regardless of where the registry value is currently stored, MC still defaults to the right panel on startup, so the registry entry seems to be ignored.

PS: When I close all tabs on the right panel then MC defaults to the left panel at startup, even when I had the empty right panel active. But as soon as I create a new tab on the right panel it reverts to activate the right panel on startup.
Then I don't know. I can't recreate that

32
Support and Feedback / Re: Version 12 * BETA *
« on: July 07, 2022, 21:02:57 »
My settings default to loading the last used tab session. But even when I change it to "do not autoload any tab session" the startup focus stays on the right panel.

Then I don't know. It should work.  I can't make it not work.

What tabs to autoload is stored here
HKEY_CURRENT_USER\SOFTWARE\MultiCommander\SessionHistory\a4c2985d9c7e4035a3221cfd600171d0\AutoLoad\

only one of them should have FOCUS=1, and that tab should be set to focus.. Unless you have something else like session that overrides that or from command line

33
If you are coping massive amount of small files and show the queue.. Then a lot of CPU time will be used to update the UI.
And if you copy lots of small files the OS will spend a lot of extra time on other things



34
Support and Feedback / Re: Version 12 * BETA *
« on: July 07, 2022, 18:31:30 »
Since MC is not build on top of Windows Shell, MC filter out network items that are not file shares.
Makes sense. The other file-managers open the browser for web-access to the network devices, which can be useful. But filtering for SMB shares likely is closer to what a file-manager is meant to do.

Quote
Auto is the tab side that was in focus when application exited last time.
I even tried File -> Exit (popup asking for confirmation) instead of using the upper right X button, same results, keeps default to right panel. Additionally I tried to limit MC to a single instance and disabled StartAllBack (which modifies the taskbar and Explorer), no dice.

Is there any more setting that I might check for this? I can live with using the "Left" setting, but to me this looks like a bug.

If you start with a TabSession that autoloads it can have configuration for what tab to activate and will override any other setting.

35
Support and Feedback / Re: Version 12 * BETA *
« on: July 07, 2022, 18:00:56 »
None of this are related new things in the beta. so moving topic
Thanks for the quick reply and moving to the proper section.

Quote
That is a settings. Explorer Panel settings. Look at "save on exit" section, there is a option if network devices should be rememberd
Turns out that the option works the other way around. By default it is set to "remember only path to local harddrive". I turned that off now.

Quote
Windows Network stuff are a mess.. MC have very little contorol. there 3 methods and you can switch between them
I get that and found a working setting after trying out all three of them. But it is noteworthy that other file-managers manage to display Windows network devices using default settings (usually not configurable anyway). And compared to MC they display and work with *all* my network devices, not just the SMB share.



Personally I don't need this often (if at all), because I can either use mapped drives or enter the IP directly. But it may be something to look into again?

Quote
The focus at startup works for me.. Maybe fails becuase of issue 1..
I tried with local and with network devices, different folders and same folders, exiting MC with the left or the right panel in focus. MC always defaults to the right panel when I open it using the "Auto" option. I don't know what "Auto" bases its decision on, though. For the time being I will use "Left", because I am more used to defaulting to the left panel.

Since MC is not build on top of Windows Shell, MC filter out network items that are not file shares.

Auto is the tab side that was in focus when application exited last time.


36
Support and Feedback / Re: Non-ASCII symbols packing bug
« on: July 07, 2022, 14:54:35 »
Zip is an OLD format that does not support enchanded characters..

Go to
Menu > Configuration > Filesystem Plugin System > FS-Zip Settings

Check "Encode filename using UTF-8"  most unpackers support this Zip Extension.

37
Support and Feedback / Re: Re: Version 12 * BETA *
« on: July 07, 2022, 14:41:00 »
Hello. Thanks for this useful application! Here is what I noticed while running the beta:

- MC does not show the last tab session when folder when it is on a mapped network drive. Instead it defaults to root C:

- A network scan only finds my Synology SMB share when I use method C (shell).

- "Auto" focus on startup always seem to default to the right panel, even when the left panel was active in the last session.

None of this are related new things in the beta. so moving topic


That is a settings. Explorer Panel settings. Look at "save on exit" section, there is a option if network devices should be rememberd

Windows Network stuff are a mess.. MC have very little contorol. there 3 methods and you can switch between them

The focus at startup works for me.. Maybe fails becuase of issue 1..

38
Updated to version 12.0.0.2885 - again crash.

From http://multicommander.com/downloads downloaded MultiCommander v11.6.0 (Build 2845) (32 bit) SHA1 : 1046D81971C39856698629AABB9505040A5A0745 and made "Upgrade", which is actually "Downgrade". And it works fine at the sam—É notebook without any additional actions on my part! Now I'm afraid to upgrade to a fresh beta. In the new versions, something is clearly broken on your side, otherwise the old version would not work either. How else can I help to solve this problem?

Im not able to reproduce that.  I tried on a Clean Win 7 SP1 and it worked.
If the crash is same as before it is becuse CPU do not like AVX2 instruction, and that is strange.

What CPU do you have ? (you can type :sysinfo in the command field in mc to get that )
The unzip code that used AVX2 is checking if the cpu support that. so it should not matter.. But maybe there are some CPU version that are reporting wrong or something.

If the crash happens again after next beta  .. not 2886 but after 2887+ then send a crash dump again, becuse since I can't make it crash I have nothing to go on.
Also before you upgrade if you can change crash dump settings to in "Core settings > Misc " to Medium or Max. That would give me more information to go on. The dumps right now dont give much more clues on what happend.

39
Support and Feedback / Re: context menu error
« on: July 02, 2022, 18:41:54 »
It actually also check other value..
the default value for .txt  and then it check if there is an entire for that in the registry for other information.

in this image the default value is  "txtfile" and then there is a reg key named "txtfile"




40
Support and Feedback / Re: context menu error
« on: July 02, 2022, 18:30:11 »
Then I don't know why it does not work for you.
I cannot reproduce that problem.

Strange is that you get some of the item for the New menu but not all.

Maybe permission that prevent MC from reading that or something ? not sure what can prevent some of them from not being shown.

41
Support and Feedback / Re: context menu error
« on: July 02, 2022, 18:08:16 »
If you just want an empty file.  You can from the Command field in MC type  "cf myfile.txt"  and it will Create a empty File at current location with that name.

42
Support and Feedback / Re: context menu error
« on: July 02, 2022, 18:06:22 »
MC get the information from the system registry.

Normally you have an entry in registry at

HKEY_CLASSES_ROOT\.txt\ShellNew\





43
Support and Feedback / Re: context menu error
« on: July 02, 2022, 17:42:40 »
I'm not sure I understand.

Text document should be in the ShellMenu > New list
It might not be in the same order as in Windows Explorer. but MC get the list of New items from the registry in Windows. so everything that is registered for 'New Item' support should show up


44
Support and Feedback / Re: Checkbox not remembered
« on: July 02, 2022, 16:07:23 »
Fix in build 2885+ (current beta)

45
Strange, because the crash is that the AVX2 cpu instructions is not allowed. 

46
I'm running Windows 7 SP1.

Already had in my system:
- Microsoft Visual C++ 2008 9.0.30729.6161
- Microsoft Visual C++ 2010 10.0.30319
- Microsoft Visual C++ 2015-2022 14.31.31103

Updated to Microsoft Visual C++ 2015-2022 14.32.31326. Rebooted the computer. But nothing helped. Crash-ID: 12-L120AF

Are you really sure it is SP1 ?
Because the crash is in the new unzip code. The new unzip code uses AVX2 CPU instruction for faster performance (If the CPU supports it).
But AVX2 CPU instruction also require OS support and that was not added until Windows 7 SP1. So that would explain the crash.
Not sure if the AVX2 support is something that can be turned off someplace in the OS.

I have it running on a clean Windows 7 Sp1 on a virtual machine.. I don't have one without Win7. can't install that anymore

Edit
you have not by any chance modified the boot kernal parameters and have run

"bcdedit /set xsavedisable 1"  ?

That would disable the OS support for AVX2.  so doing "bcdedit /set xsavedisable 0" should enable it again..




47
Yes. I can open MC_LangPack_en.zip and MC_LangPack_ru.zip files with Windows Exporer. I even checked the archives for integrity in Winrar 6.11 and 7-zip 21.07 and 22.00- No errors found. Can I provide any additional information to solve the problem?
Also are you running Windows 7 or Windows 7 SP1 ?

48
You can try to install the Microsoft VC Redist 14.32
https://docs.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170

It should be built into the exe, but Windows 7 is weird. and might require as a side by side install.


49
(Move topic to Beta section, since v12 is only out as beta..)

According to the crashdump it is when trying to read the language file. I can't see exactly what since the minimum crashdump does not contain any data.
The crash location is very strange and should not even be possible to happen.
Maybe <appfolder>\Languages\MC_LangPack_en.zip got corrupted ? can you open that file with Windows Exporer ?


50
Beta Releases / Re: Version 12 * BETA *
« on: June 19, 2022, 11:18:46 »
I can't make it fail. strange. will check more about it tomorrow.

Follow-up to this problem:

I deleted my test environment completely
Copied my (working) complete live environment to a separate physical drive
Launched the new test environment and checked for updates
It updated to build 2880 and...

No modified Dates  :(
Strange, I cannot reproduce that, I tried to change to different date/time settings that are in MC.. But it works.
Most be some conflicting settings or something. But can't reproduce it.. very strange

Also normal 'date' column is Last Modified date.. they should match on normal NTFS filesystems.

Pages: 1 [2] 3 4 5 6 ... 161