Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mathias (Author)

Pages: [1] 2 3 4 5 ... 156
1
Support and Feedback / Re: Go up ".." don't show
« on: November 28, 2021, 17:54:34 »
I have exactly the same problem. It must be something with windows 11. After update, cant see [..] in first level folders. Could you please update it, so it does not respect the hidden folder [..]?
try the current 11.5 beta

2
Not sure if I remembered it wrong that
before I upgraded recently,
subfolders were included when filtering or searching.
Now no matter when filtering or searching(F3)
filenames with my keyword in subfolders cannot be found.
You might have change the "Sub Levels" option in the search dialog. if this is "0" then it will not search in subfolders.
Normally you want it set to "All"


3
Support and Feedback / Re: filtercreate
« on: November 20, 2021, 17:19:43 »
Hallo.
Trying an searching I solved the problem.
I write the solution here for any interested:
MC.Explorer.GetViewFilter;
MessageBox( "test", $__CMDRESULT, 0 );

I suggest you to explain better the meaning and the use of $__CMDRESULT in the manual, AND explain better the use of MC.Explorer.GetViewFilter and other "get" functions.

Archimede

MC.Explorer.GetViewFilter command are not a normal MultiScript command. it is a CustomCommand. this are simple commands that access things in MC via the same way the UI is. eg like when you click on something,
And MultiScript can call this higher level commands. problem is that they are fire and forget commands.. they can't normally return anything.

Normal MultiScript function acts with core function in MC.  problem is set/getfilter is somethings that exists in a higher UI level.
An the _CMDRESULT is a workaround to let some special custom commands return back information to the MultiScript engine



4
Support and Feedback / Re: FTP server and cyrillic
« on: November 20, 2021, 17:14:24 »
Currently there is no way to force MC to use UTF8 with ftp servers.

When connecting to a FTP server, MC will ask the ftp server about what features it support and if it say it support UTF8 then UTF8 will be used for getting file list and such.

If you look in the ftp connection log, at the beginning is there a "> FEAT" line ? and the following list after that is a list of features the FTP server support.

5
Beta Releases / Version 11.5 BETA
« on: November 20, 2021, 17:08:22 »
This is the beta release of the next version. It has not been fully tested.
If any of the function listed below have issue please report them
If you find issues that about things not in the list below. Then post a normal bug report in "Support and feedback" section.


-- Build 2333  - 15+ Changes
  CHANGE- Upgrade build process to VS2022
  FIXED - Issue with MultiScript CopyFile(..) , Progress dialog was not able to be shown.
  FIXED - Issue when open path from locked tab, Some configuration option resulted in 2 new tabs opening instead of 1
  FIXED - Never hide ".." folder even if file attribute say so
  REMOVE- Lots of unused code that was not used anymore since it was rewritten.
  FIXED - 6 Stability Issues



6
Feature Requests and Suggestions / Re: themes
« on: November 07, 2021, 22:53:08 »
Sorry, but where would i find the filelist?
Eh? the Explorer Panel have a filelist, It is the list where you see all the files and folders of a path.

7
Feature Requests and Suggestions / Re: themes
« on: November 07, 2021, 17:56:17 »
You can configure all the colors inside the filelist, but theme for buttons and UI elements. there are only standard and dark

8
Support and Feedback / Re: filtercreate
« on: November 06, 2021, 10:59:04 »
Look at the UserDefinedCommands under the Examples section. There is a MultiScript named "Create Filter and Select"

This script works for me, so it should work.
Or maybe there is something else in you the script that makes it fail.

9
Eh ? I don't understand. Foxit complain about signature for MC when you open a pdf ?

Well MC is not digitally signed if that is what foxit complain about.
Should be some way to allow it in foxit I guess. Never used foxit so don't know.







10
Support and Feedback / Re: auto sort after name chagne does not work
« on: November 01, 2021, 07:21:52 »
How do you drag a tab from left to right side?
Ehh you just drag it by by dragging the tab (where the tab name are)  left panel to right panel side,
You can also swap two panel with each other with ctrl+U

11
Support and Feedback / Re: Bug when double clicking a file
« on: November 01, 2021, 07:18:54 »
Maybe you moved the mouse while doing it so it got dragged into a folder ? Or security software did not like that exe and put it in quarantine

12
Support and Feedback / Re: auto sort after name chagne does not work
« on: October 31, 2021, 01:26:43 »
Strange, they are the same no matter what pane side it is. If you drag a tab from left to right panel side. does that work ?

13
It would be very nice idea to be able to open external program say notepad.exe inside one of the panes  so you can monitor changes for example while working with files , this option would be good if one can drag the external program into the pane and then have the option to lock it so no other drag can happen by accident until option unlocked.

Thank you
Aziz

That is not possible. You cannot run an external program inside another unless that external program is designed for it.

14
You mean the Windows Explorer Progress bar?  If you do Paste or SendTo the copy is handled by Windows. MC have no control over that progresssbar since it is not created by MC

15
Support and Feedback / Re: Locked tabs bug - open 2 tabs
« on: October 28, 2021, 18:39:27 »
Yes I notice that some days ago. Will be fixed for next version.

16
Often when it hang at startup it is because it get stuck trying to get information from some device.  If you got some strange remote drives try to disconnect that,
You can also check the application log and see what it get stuck on there

17
Support and Feedback / Re: Go up ".." don't show
« on: October 27, 2021, 07:21:48 »
Something must change it or something you have hook it self into windows and change the information that MC receives. OR some settings in Windows 11 do it.
I don't know. But I cant replicate it on my windows 11.

18
Support and Feedback / Re: Go up ".." don't show
« on: October 25, 2021, 22:19:22 »
Remove hidden attribute from the root and it will work.
How you set hidden attribute to the root to begin with I dont know.

19
Support and Feedback / Re: Go up ".." don't show
« on: October 25, 2021, 20:32:45 »
MC respect the hidden attribute,  think is that for ".." maybe it should not. Not sure

Question is how you where able to set the ".." to hidden, since it points to the root.

20
Support and Feedback / Re: Go up ".." don't show
« on: October 25, 2021, 17:50:09 »
I cannot reproduce this even when I sort folders/files by Ext (as you do).

What version of MC are you using and is it Installed or Portable?


Now I'm using version 11.4.2831 (lastest), but win I instal Windows 11 (version Windows 11 pro 21H2 22000.282) with MC version 11.2.0.2795 (Upgrading first and fresh install later after fist time I see the problem).

Oh...btw... I use installed version

UPDATE: I uninstalled MC again and reinstall it with no custom options...same issue (image attached)

UPDATE2: In aaa picture I show you that [..] symbol appaers but If select "show hide files and folders"

Then the ".." folder has the HIDDEN file attrbiute set, Normally you are not able to change file attributes of the ".." folder so not sure how that have happend.

21
Support and Feedback / Re: Go up ".." don't show
« on: October 24, 2021, 15:27:41 »
Z: is my game physical disk (just change letter).
This happen in any folder, any disk, created by me or creater by windows intallation. ".." dissapear in fist level folder (I don't know if this is correct terminology...I refer at fist folder after root)

I already check for my Windows 10's multi commander, and show ".." in the same leves that win11 don't.

For normal filesystem MC do not add a the ".." item it self. It should be provided by the filesystem.
For that I thought that is a win11 issue (maybe new version of file explorer)

Don't think it is Win11. also MC is not built on top of Windows File Explorer.
I don't know why that is happening for you.. Never seen that happen.
It is not that the ".." folder has hide attribute set ? and your MC is not set to show Hidden/System files ?

22
Support and Feedback / Re: Go up ".." don't show
« on: October 24, 2021, 14:58:40 »
Is it only your Z: drive ? Is that some special network device ? something special with it? When MC scan the filesystem it should returns a ".." item, For normal filesystem MC do not add a the ".." item it self. It should be provided by the filesystem. MC only added it for virtual folders.
So something is different with your Z: then a normal filesystem.

23
Support and Feedback / Re: Go up ".." don't show
« on: October 24, 2021, 13:52:51 »
I never seen anything like that. And I do not thing it is a Windows 11 thing.

Is there something special with the folder with the missing ".." ?
Is it your own folders or system folders ?


24
Support and Feedback / Re: Columns for Metadata?
« on: October 23, 2021, 12:52:31 »
Right click on column header and go to customize column.. And you can add some column with meta data.
However Author and title is currently not available

25
Support and Feedback / Re: Auto sorting now working right?
« on: October 20, 2021, 12:20:49 »
When changing settings for Explorer Panel it affects all panels so they should get the same settings.
I'm not able to recreate it. Both panels resorts for me. Sure you are sorting on the name column in both panels ?

Pages: [1] 2 3 4 5 ... 156